1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: explorer.exe error 0xC0000022 when user switching

Discussion in 'Windows XP' started by UltimaDestroyer, Jan 14, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. UltimaDestroyer

    UltimaDestroyer Thread Starter

    Joined:
    Sep 26, 2007
    Messages:
    23
    whenever i try to switch users, from my administrator account to a limited account, i get the "loading settings..." screen, then an error pops saying explorer.exe terminated unexpectedly, with error code 0xC0000022. i can log into my admin account fine, but not into the limited account.

    first off, this is not a malware issue, since i just did a clean install. and i got this issue once before after doing a clean install as well. that time i just deleted the limited account and only used the admin account, but now i want to have a limited account for other people to use.

    i did some googling a found out (incorrectly/correctly not sure which) that it this error has something to do with user access rights.

    like i said its a clean install. i installed windows xp sp3. got all the updates from microsoft update. i installed my drivers (intel chipset+network connection, realtek audio, nvidia drivers, keyboard+mouse, 9 drivers in total, latest versions).

    then i installed apps i regularly use like firefox, xfire, steam, ccleaner, etc.

    the thing i think may have cause this error, is that i installed a custom theme (royale noir to be exact) so i had to patch uxtheme.dll using uxtheme patcher sp3. and i replaced msgina.dll and shell32.dll with modified versions (different bitmaps).

    so is this a user permissions problem? or is it the files i chnaged? or both? or something else?

    any help is appreciated, thanks
     
  2. Saga Lout

    Saga Lout

    Joined:
    Sep 15, 2004
    Messages:
    3,791
    In Control Panel>Network Connections, look in the relevant connection's Properties - do you see Client Services for Netware in the centre pane? That can cause user switching problems but in your case, I agree - it's the non-standard theme that could be causing this.

    I had lots of problems with one of those uxThemes in a system the other day and would not recommend its use at all.
     
  3. UltimaDestroyer

    UltimaDestroyer Thread Starter

    Joined:
    Sep 26, 2007
    Messages:
    23
    after doing some more googling i found a command that fixed it.

    it seems the problem was indeed with my custom theme, my modified shell32.dll to be exact
    my modified msgina and uxtheme dont cause problems

    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    running that command seemed to fix it, though it deleted the account that i couldnt log into so i had to make a new one, but the new one worked. im not exactly sure what it does. i think it resets the security permissions to default maybe? i wouldnt recommend people use it unless they know what it does or are willing to take the risk.

    in any case, problem solved

    thanks saga lout for your input
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/974713