1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: External HD not Recognized

Discussion in 'Hardware' started by Wavestrike, Dec 29, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. Wavestrike

    Wavestrike Thread Starter

    Joined:
    Dec 29, 2011
    Messages:
    4
    I've just bought a 500GB Verbatim USB 2.0 External HD, and have been having trouble getting it working on my Windows 7 desktop since the get-go.
    I have tried many different methods and searched many forums, including this one; and usually I am great with stuff like this, but no luck.

    - It is not listed in My Computer, or even in Disk Management; only Device Manager.
    - It is listed in Device Manager with a yellow '!' ; The drivers for this device are not installed. (Code 28)
    - When I plug it in, Windows searches, but can't find a driver to install for "WDC WD50 00BEVT-00A03T0 USB Device
    - It works PERFECTLY on my mother's Windows 7 Laptop (plugged in, windows update installed driver, done)
    - Also works and detects no problem booting from a Ubuntu Live CD on my desktop (which I need it for)
    - My friends' external HD's also did the same thing, but detected & worked fine to copy files in ubuntu or other PC's/laptops

    Things I have tried:
    - Switching USB cords, ports
    - Uninstalled, rebooted, unplugged/plugged back in
    - Having it plugged in before/after OS bootup
    - Installing newest chipset drivers
    - Microsoft FixIt (No device driver found)
    - Deleting UpperFilters in the proper registry file (backed registry file up as well)
    - Re-Formatting the External HD
    - Windows 7 Installation Disc (Repair)
    - Switching to AHCI from IDE, and back

    It simply can't find a driver, and I have scourged the internet looking for a driver, but most sources say windows should install the driver automatically.

    TL;DR
    External HD shows in device manager, but not disk management, works fine on laptop, or in ubuntu. No driver being installed.
    Help me.

    Code:
    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft Windows 7 Ultimate, 64 bit
    Processor: AMD Phenom(tm) II X2 550 Processor, AMD64 Family 16 Model 4 Stepping 2
    Processor Count: 2
    RAM: 3581 Mb
    Graphics Card: ATI Radeon HD 4290, 624 Mb
    Hard Drives: C: Total - 476929 MB, Free - 84170 MB;
    Motherboard: Gigabyte Technology Co., Ltd., GA-890GPA-UD3H
    Antivirus: ESET NOD32 Antivirus 4.0, Updated and Enabled
     
  2. sonexpc

    sonexpc

    Joined:
    Mar 31, 2011
    Messages:
    663
    try use MSconfig and start up in Diagnostic Startup and try to plug in the USB WD Ext HD ... see is there any conflict with any start up program.... seems is just software issue..
     
  3. Wavestrike

    Wavestrike Thread Starter

    Joined:
    Dec 29, 2011
    Messages:
    4
    Just tried, and still the same result, doesn't get the driver.

    I'm just short of installing windows right now, .. and I really do not want to do that just to get this HD to detect.
     
  4. sonexpc

    sonexpc

    Joined:
    Mar 31, 2011
    Messages:
    663
    Do you try it in safe mode?
     
  5. fairnooks

    fairnooks Banned

    Joined:
    Oct 1, 2007
    Messages:
    5,251
    Since it seems the drive is fine, it must be your system. Do you have any other mass storage devices you can plug in and do they work or same failure?
    You say uninstalled, but what did you uninstall?
    If it wasn't the USB conrollers and USB mass storage devices, try nixing all of them from device manager and then reboot to let them install fresh.
     
  6. Wavestrike

    Wavestrike Thread Starter

    Joined:
    Dec 29, 2011
    Messages:
    4
    Thanks for the suggestions, but I really tried almost everything.
    (To the last post - yes, I tried both uninstalling the USB Mass Storage Device from device drivers, as well as the hard drive itself, multiple times, with different selections for the location of the folders.)

    Anyway, whatever the problem was, I gave up.
    I'm assuming something (inf file?) was corrupted in the winsxs folder - or something.
    Ended up re-installing windows 7 and left it plugged in during the install; and it was in my computer the second I got a chance to check.

    Any admins can close this thread/mark as solved, thanks.
     
  7. dustyjay

    dustyjay

    Joined:
    Jan 23, 2003
    Messages:
    12,661
    First Name:
    Jay
    Wavestrike you can mark your own Thread solved if you wish. Glad it was solved by a Windows Reinstall. At least it is working now.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1033506

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice