1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Family Tree Maker 2008

Discussion in 'All Other Software' started by kimberleyallen, Jan 18, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. kimberleyallen

    kimberleyallen Thread Starter

    Joined:
    Nov 18, 2006
    Messages:
    35
    I purchased Family Tree Maker 2008 last year and I have had nothing but problems with it and I desperately need some help!

    I had repeated problems with it right from the start where for no apparent reason the file seemed to become corrupted and as soon as you opened it there was an error and the program closed. I have kept having to reinstall it and start new trees and then open it twice, one version open with the error message ignored so that I could copy my information, the other version being the new tree that I had to manually transfer all my entries into…very laborious! I ended up with about 6 trees and never managed to get all the info across before the next new tree failed…it drove me crazy!

    Then it got worse and the program wouldn’t even start at all! Before, the program got a chance to open before the error message came up and if you ignored it you could at least see your entries. I uninstalled, rebooted and reinstalled multiple times but the program just would not start. I was installing from the disc and all seemed to be going fine and it said it had installed successfully but as soon as you tried to start the program there was an immediate error message and it automatically closed.

    I contacted Ancestry Support and after many emails and many procedures, all to no avail, I finally telephoned Ancestry in America (I am in the UK). They promised to send me a new disc out, it never arrived.

    I was so frustrated that I gave up and stopped using the program, stupidly hoping that in time it might sort itself out. That was 6 months ago. Then the 1911 Census came out and re-ignited my interest and so I renewed my Ancestry subscription and set about trying to sort the problem once again.

    I searched on Ancestry and came up with some advice for this problem which other people seem to be having too. Below is the advice and what I have done so far, and some screenshots. Can ANYONE can help me with what to try next?!!! I'm so fed up, I can’t access my tree or the data at all, I’m hoping all my work has not been lost!

    Advice on Website
    Before you manually remove the program you should do the following:
    Uninstall and reinstall the Family Tree Maker program with all security programs temporarily turned off. If you cannot temporarily turn off the security programs follow the ‘Clean Boot’ instructions by clicking here.


    Uninstalled, completed System Restore
    Reinstalled and Uninstalled again with Virus Software disabled


    Screenshots after installation

    [​IMG]


    [​IMG]

    Screenshots after Removing Program
    [​IMG]

    Advice on Website
    Manually removing program entries and items in a system will not resolve issues of ‘Program has encountered a Problem and must close’ if there is an issue with the ‘User Profile’. For Windows XP users you go to Start, then Control Panel, then to ‘User Accounts’. There is a ‘Add’ option where you can add a User Profile. If you do this you need to then reboot then Log In under that username.


    Have created an additional User Profile, rebooted and logged in using that Username - It made no difference

    Also before trying the Manual Removal makes sure to check for any Windows Updates that may be available. Easiest way to do this is to open Internet Explorer, go to Tools at the top and click on Windows Updates. When it checks your system click on ‘Express’ when it comes up and download and install any that show up. Repeat this step until it has no more updates available.

    Have checked for all updates. Service Pack 3 is installed, no more updates available

    Last item before following the below steps would be to move the Family Tree Maker folder from your ‘My Documents’ section. Go to Start, then to ‘My Documents’ and left click on the ‘Family Tree Maker’ folder and hold the mouse button, and drag over to a blank spot on your desktop. Try opening the program again (this will determine if it was a Family Tree Database error that causes the program to not open properly.


    There is no ‘Family Tree Maker’ folder within My Documents

    Reasons for a Manual Uninstall of Family Tree Maker 2008
    With the above steps already performed and the program still will not open and ‘encounters a problem and must close’ or in the ‘Add and Remove Programs’ you have removed the program but there still remains a ‘Family Tree Maker 2008’ entry. Below are a few indications a manual removal may be necessary:

    Message for ‘runtime error’ or ‘missing components’ message comes up.
    Note: This often happens when they have a ‘System Restore’ done recently and our program stops working properly.

    The Uninstall and reinstall doesn't always work due to ‘application data’ being left behind as well as some registry entries.
    The below steps should resolve some ‘encounters a problem and must close’
    Add and remove program still listed after being uninstalled
    Most runtime or missing component errors issues.
    Note: If you have other reasons for a Manual Uninstall please respond with the symptoms or error message that comes up if you email or speak with Technical Support.


    Manual Removal Steps

    Attempt the normal remove of Family Tree Maker
    Go to Start, Control Panel, Add and Remove Programs, then select Family Tree Maker 2008 and Click Remove, then follow instructions.
    If this encounters a problem try doing the removal via reinserting the FTM CD and go through the Install then Remove options.

    Completed

    Remove any FTM program files left behind
    After the auto uninstall has been done go back to Start, My Computer (Computer in Vista), Local C: Drive (sometimes named differently but should still be the C: drive), Program Files, then find the Family Tree Maker folder (either v16 or 2008 etc) and delete the folder.

    Completed, folder was present

    Remove the folder listed as ‘The Generations Network’
    After the above steps have been done, click on the ‘Up’ arrow icon (Folder with green arrow at the top of the open window) and click on ‘Documents and Settings’ or go through Start again and click on C: Drive then ‘Documents and Settings’ there.
    Then click on their user name and look for a ‘Application Data’ folder that is faded
    Note: if you can’t find it go to ‘Tools’ at the top, then ‘Folder Options’ then ‘View’ and checkmark the ‘Show Hidden Files and Folders’ and apply then ok).

    In the Application Folder locate the ‘The Generations Network’ folder and delete it if its present, skip this if its not listed.

    Completed, folder not present

    Clear out registry items that Family Tree Maker 2008 created
    Go to Start, then Run (In Vista you can go to the Task Manager then File and the Run there), and type Regedit.
    First always make a backup of the registry; File, then the second option ‘Export File’ (Not the Import which is different).
    Make sure at the bottom right the ‘Pip’ in the radial button says ‘All’ then give it the name ‘Backup’ and Save to the Desktop.
    Next click on the plus sign to expand (Arrow sign in Vista) the “HKEY_Current_User”, then Expand ‘Software’, then click on ‘The Generation Network’ folder and delete.

    Completed, removed folder

    Next go to ‘HKEY_Local_Machine’ and click on the plus sign, then expand ‘Software’, then click on the ‘The Generations Network’ and delete the folder.
    Completed, removed folder

    Note: For the FTM v16 click on the ‘MyFamily.com’ folder and delete if you are removing this program as well, otherwise leave.
    Completed, removed folder

    Removing a failed uninstall of Family Tree Maker 2008
    If the Add and Remove Programs had a leftover item in the list for FTM that did not remove in the Auto Removal method you need to do an extra step in the Registry.

    After you have done the previous Registry cleaning and you are in the ‘HKEY Local Machine’ and under ‘Software’ section, click on the plus sign next to ‘Microsoft’ and scroll to the entry for ‘Windows’ and expand that (plus sign).
    Then click on ‘CurrentVersion’ plus sign (expand) then scroll down to ‘Uninstall’.
    Here you then have to click on each of the bracketed number and letter entries and if it says Family Tree Maker (v16 or 2008) then delete that Registry folder entry (may take a few minutes and explain to the customer it will be in the DATA column and usually the first ‘DisplayName’ row will have our name, if not skip to next).

    Completed, no folder present

    The last step before reinstalling you will need to clear the cache and cookies.
    For instructions on how to clear cache and cookies please click here.
    Note: Make sure all programs are closed before clearing the cache and cookies.

    Completed

    Reinstall your Family Tree Maker. First, turn off any software security
    Turn off any main security firewall.
    Insert CD and choose to Install and follow install directions.

    Completed, still receiving ‘Program has encountered a Problem and must close’
    Cannot install patch as program will not open, above error message appears.


    Download any update or patch that is available (skip or ignore if this caused the original issue with the ‘encounters a problem and must close).
    Register the Family Tree Maker Program
    Open a data file if it is not automatically detected (remember you may have been asked to move it to the desktop in the ‘Family Tree Maker’ folder.


    No data file to open. Also tried to install the patch but get the error messages
    "Missing or Invalid Registry/INI entry" and "Old file does not exist"

    Also attempted to install Microsoft WSE 3.0 Runtime as per further Ancestry advice but encountered problems, see screenshots


    [​IMG]

    [​IMG]

    Get the same errors with modify, repair and remove options. Then I unchecked all the features and with only runtime feature checked it seemed to install ok and is listed in the Add/Remove programs list.

    HELP! :eek:
     
  2. StumpedTechy

    StumpedTechy

    Joined:
    Jul 7, 2004
    Messages:
    7,232
    I noticed the Dotnet error and did a search on the error number and my thoughts are confirmed.... Have you checked the versions of Dot net you have installed and made sure they are all installed right. Here is an option below

    http://genforum.genealogy.com/install/messages/18591.html

    If you follow the followups - http://genforum.genealogy.com/install/messages/18592.html and http://genforum.genealogy.com/install/messages/19370.html they indicate working with dot net and making sure you have 2.0 or later.
     
  3. kimberleyallen

    kimberleyallen Thread Starter

    Joined:
    Nov 18, 2006
    Messages:
    35
    Oh my God...thank you SO much! Repeated all the previous steps to remove the program...yet again. Then I downloaded Microsoft .NET Framework 3.5 Service Pack 1 and installed it as suggested. Then reinstalled FTM again and with my heart in my mouth watched it progress, it got closer and closer to looking like it was finally going to work and it did! I couldn't believe it, it even opened and downloaded various updates. I have spent so many frustrating hours trying to sort this out and in the end it was so simple...shame Ancestry Customer Support couldn't have come with this!

    Thank you again. So sad that I am so excited about finally solving this but I am and what's more....I love you!!! :)
     
  4. StumpedTechy

    StumpedTechy

    Joined:
    Jul 7, 2004
    Messages:
    7,232
    Very sad since this came from a geneology website that has a forum devoded directly to their product....


    I am VERY glad to have helped. You also may want to get with customer service to find out if you can get any type of extended subscription time due to the time lost when you could not access the program.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/791771