1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: File Sharing Vista problem

Discussion in 'Networking' started by PopPicker, Dec 1, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. PopPicker

    PopPicker Thread Starter

    Joined:
    Sep 21, 2004
    Messages:
    637
    Well, I've a network of a few PC's some running Win2000 and some XP, I've a new PC with Vista.

    I've set up users on the Vista PC but none of them can log into it. A window pops up saying,,

    Logon failure: the user has not been granted the requested logon type at this computer.

    The Vista PC can access all of the other machines without issue.

    What have I done wrong?

    PP
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    The users do not have permission to connect to the remote computer. To resolve this problem: on the remote computer, select Administrative Tools>Local Security Settings>Local Policies>User Rights Assignment, right-click on Access this computer from the network>Properties>Add Users or Groups, add everyone or any users you want to be able to access the computer from the network.

    Also check "Deny access to this computer from the network" and make sure no everyone or LAN users are denied to access this computer.
     
  3. PopPicker

    PopPicker Thread Starter

    Joined:
    Sep 21, 2004
    Messages:
    637
    Thanks for your reply, however I don't have 'Local Security Settings' in the Administrative Tools list. Is it hidden?
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
  5. PopPicker

    PopPicker Thread Starter

    Joined:
    Sep 21, 2004
    Messages:
    637
    Thanks John, that link helped wonderfully. Especially this paragraph:

    Set the Network Location Type to "Private". This requires that your computers are secure, behind a perimeter firewall or a NAT router, and opens the standard Vista personal firewall to allow Server Message Blocks (SMBs) to pass between the computers. If your computer is directly connected to your Internet service, either get a NAT router, or leave the Network Location Type set to Public (which will prevent you from networking this computer).
    Having set the NLT to "Private", you must now designate which services you wish for your server to provide or use. You should verify each setting before continuing, and change it if necessary.
    File sharing.
    Public folder sharing.
    Printer sharing.
    Password Protected Sharing (PPS) affects the above 3 services. Disabling PPS is the equivalent of enabling Simple File Sharing, in Windows XP.



    I now have all the machines chatting away like old mates.

    Thanks again

    PP
     
  6. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Glad you got it going. :)

    You can mark your own threads solved using the thread tools at the top of the page in the upper right corner.© :)
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/658057

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice