1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Firefox won't play videos now! WHY? Help please!

Discussion in 'Web & Email' started by nzcpc, Mar 15, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    Hi guys

    Recently switched from IE to Firefox, was all going good, until I updated to the latest flash player a couple of days ago. Now Firefox won't play YouTube videos.

    See below for a recording of what happens when I try to view the YouTube videos:

    http://www.youtube.com/watch?v=GykWJ3SLJnI

    (by the way when viewing the video in this post it works fine on my computer in Firefox!)

    Does anyone know why this happens? I've got the latest Firefox and latest flash player so not sure why this is happening, have tried a Google search but they all say to update everything, which is already done.

    YouTube videos play fine in IE on my computer. So is it Firefox? Or a virus? Or?

    HELP PLEASE! Thanks.
     
  2. TheShooter93

    TheShooter93 Cody Malware Specialist

    Joined:
    Jul 9, 2008
    Messages:
    11,013
  3. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    Of course. Any other idea's?
     
  4. TheShooter93

    TheShooter93 Cody Malware Specialist

    Joined:
    Jul 9, 2008
    Messages:
    11,013
    After installing the latest version on Flash Player, are you able to watch Youtube videos on Internet Explorer?

    I just want to make sure it's solely a Mozilla Firefox issue.
     
  5. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    Yea I've already got everything up to date.
    And yep plays fine in IE. It's isolated to Firefox it seems.. except when the video is embeded I can watch it fine, so it's like it's only on YouTube that the issue occurs?

    E.g. YouTube video's embeded on Facebook will play fine, and the YouTube video I posted on here plays fine.. in Firefox.
     
  6. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,056
  7. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    Yea had tried that before, and just did it again.
    Same result - didn't work.
     
  8. TOGG

    TOGG

    Joined:
    Apr 2, 2002
    Messages:
    5,700
  9. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    No I didn't as it didn't say you needed to?

    So, just ran it the uninstaller, restarted, ran uninstaller again, restarted again, then download installer and installed latest version.. same outcome. Still won't play videos properly on YouTube.
     
  10. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,056
    Have you tried disabling NoScript in Firefox?
     
  11. dvk01

    dvk01 Derek Moderator Malware Specialist

    Joined:
    Dec 14, 2002
    Messages:
    47,835
    do you have 3rd partyy cookies blocked in FF
    when they are blocked you sometimes get this problem
    Or what other firefox extensions do you have that might be casuing a clash
    Certain video downloader helpers will do this as you tube try to block them when they are detected
     
  12. drunkeded

    drunkeded

    Joined:
    Mar 16, 2011
    Messages:
    3
    I've been having this same problem. Youtube videos play fine on FB but on youtube itself it only plays the music. If i restart comp then i can play 1 video correctly on youtube but then the rest won't play. I've even tried reinstalling it too. And i've had firefox for years and just now started this about a week ago. Any other ideas?
     
  13. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,056
    Have a look at post #13 HERE and see if it applies to you.
     
  14. nzcpc

    nzcpc Thread Starter

    Joined:
    Jul 22, 2010
    Messages:
    99
    Ok first of all how do I disable No Script and where is it??

    Second, nope third party cookies are enabled until they expire.

    Don't have any extra extensions or add-ons or downloads EXCEPT a skin/theme by FireFox. So no download helpers or nothing.

    Post #13 I've tried before, and it did work, it made YouTube videos work, but then on FaceBook etc it wouldn't let me play embedded videos as it said I needed to Update or get Flash Player or something along those lines.

    WHAT THE HECK IS GOING ON!!
     
  15. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,056
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/986117