1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Google Chrome didn't shut down correctly error-Restore session bug. Please he

Discussion in 'Web & Email' started by KendraDit, Jan 28, 2014.

Thread Status:
Not open for further replies.
Advertisement
  1. KendraDit

    KendraDit Thread Starter

    Joined:
    Dec 23, 2013
    Messages:
    16
    Computer/Browser details
    OS Version: Microsoft Windows 7 Home Premium, 64 bit
    Processor: Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz, Intel64 Family 6 Model 37 Stepping 5
    Processor Count: 4
    RAM: 3890 Mb
    Graphics Card: Intel(R) HD Graphics, 1721 Mb
    Hard Drives: C: Total - 463566 MB, Free - 282593 MB;
    Motherboard: TOSHIBA, NWQAA
    Antivirus: Microsoft Security Essentials, Frontier Secure

    Chrome Version: 32.0.1700.102


    Extensions: Ad block 2.6.18, Ad block Plus 1.7.2, Add to Amazon, HTTPS Everywhere, Image Properties Context Menu, Imagus, Session Manager .4, and the Great Suspender.


    Problem: I keep getting this yellow ribbon error upon startup.

    It says that Chrome didn't shut down properly and wants to restore the last session. However, closing tabs/windows and restarting Chrome will produce this same exact message. Additionally, tabs opened in Incognito will be reopened. I've went to Chrome://crashes, but I don't have a crash i.d.

    What I've done: I have updated to the latest chrome version, as well as cleared browser cache/cookies. I have gone to user\appdata\local\google\chrome\userdata\default\cache and deleted that file, but the problem still persists.

    I have no idea how to fix this problem and google forums isn't helpful at all.

    Thank you to anyone that can offer a suggestion!
     

    Attached Files:

  2. Rollin_Again

    Rollin_Again

    Joined:
    Sep 4, 2003
    Messages:
    4,912
    Try to reset the browser settings first:

    Click the Chrome menu on the browser toolbar.
    Select Settings.
    Click Show advanced settings and find the "Reset browser settings” section.
    Click Reset browser settings.



    If that doesn't work I'd try renaming the "default" folder to something else like "default_old" and then restart Chrome and let the folder get re-created automatically for you.


    Rollin
     
  3. KendraDit

    KendraDit Thread Starter

    Joined:
    Dec 23, 2013
    Messages:
    16
    Okay, so I did the first part (resetting browser settings) and it didn't work. However, I did do the second suggestion of renaming the default file. It worked! I no longer got the restore session error. Thank you so much. You have no idea how frustrated I was getting about this problem and about the lack of response in Google Forums. Seriously. Thank you!
     
  4. Waterwynd

    Waterwynd

    Joined:
    Mar 1, 2014
    Messages:
    1
    I read thru numerous solutions with this issue of banner "google chrome didn't shut down properly." Solutions like: The name change on default folder to deleting all extension files- which didn't correct the issue because of Google's sync. I removed the entire google chrome, including all subfolders and personalized data so I can't know if that was necessary. Because I did that- I realized the issue was with Google Sync- as it simply uploaded the same information and therefore error message.

    SOLVE: Under Settings go to Advanced Sync (top of settings page) and click on "choose what to sync" - remove Extensions (and Apps if you use a lot of apps) from sync. Then you may opt to delete all extension files: computer- c drive- user file (your name) -appData (make sure under folders in control panel that your folders are not hidden from view) - Local - Google - Chrome - User Data- Default- Extensions. You can search each extension folder to see which one you think is the issue from extensions remaining active post shut down of chrome and remove only those (do not track is one that doesn't shut down reliably). Also ensure that apps aren't permitted to run once Chrome is shut down. You may want to remove App Sync also; I don't use many app's so it's not an issue for me. I found it easier to just delete all extension folders and just start again. Without sync= no issues. I didn't change any extensions/apps when I added them back to Chrome and continue to have no issues now that sync is discontinued.
     
  5. vegaboy

    vegaboy

    Joined:
    Mar 3, 2014
    Messages:
    1
    I've got the same issue
    thanks for sharing your guide to us
     
  6. pspirn

    pspirn

    Joined:
    Mar 17, 2014
    Messages:
    1
    About the solution (below), where do I find the 'default' folder? Is it in Google settings or Windows 7?

    "If that doesn't work I'd try renaming the "default" folder to something else like "default_old" and then restart Chrome and let the folder get re-created automatically for you."

    Thanks
     
  7. avlncuser

    avlncuser

    Joined:
    Apr 23, 2014
    Messages:
    2
  8. onkelp

    onkelp

    Joined:
    May 5, 2014
    Messages:
    2
    Thanks for the link. I followed the instructions, everything works except for the bookmarks.
    I copied the bookmark.bak file into the new default folder and renamed it. How can I import it into chrome?
     
  9. avlncuser

    avlncuser

    Joined:
    Apr 23, 2014
    Messages:
    2
    I used the chrome export command from old chrome, and used import in the new chrome.
     
  10. onkelp

    onkelp

    Joined:
    May 5, 2014
    Messages:
    2
    Unfortunately, I didn't export from the old chrome. I somehow oversaw that.

    The link says to copy "Bookmarks.bak" file from old default into new default and rename. I have done that. Just don't know what the next step is in order to get my bookmarks in the new chrome.
     
  11. rljohnsen

    rljohnsen

    Joined:
    Dec 19, 2010
    Messages:
    4
    First Name:
    Bob
    Close Chrome. Navigate to <user>\appdata\Local and rename the Google folder to Google.old (or delete it). Reopen Chrome - it will act like a clean install, and (if you have an account) set up your saved account preferences. Problem solved.
     
  12. sjm-mk

    sjm-mk

    Joined:
    May 28, 2014
    Messages:
    1
    Hi
    This was happening to me too. I found that inside the Preferences file "%UserProfile%\AppData\Local\Google\Chrome\User Data\Default\Preferences" near the bottom of the file (inside the Profile section) this line:
    "exit_type": "Crashed",
    Once I modified the line to read "normal" instead of "Crashed" like this:
    "exit_type": "normal",
    the problem disappeared.
    Hope this helps.
    Cheers,
    Shaun
     
  13. prepressgirl

    prepressgirl

    Joined:
    May 29, 2014
    Messages:
    1
    This fixed it! Thank you so much. I had to turn off "hide protected system files" or something like that before I could see the file. Then, since I was editing in notepad, my file was saved with .txt extension, so had to delete old file and rename new file (delete extension) but Chrome is happy now! Thank you!!!
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1118647

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice