1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Help fixing services plz

Discussion in 'Windows XP' started by MJT27, Mar 16, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. MJT27

    MJT27 Thread Starter

    Joined:
    Feb 1, 2004
    Messages:
    159
    Im running win xp home with SP3

    When I click View running services link in the Advanced System Information
    section in Help and Support Center, I encounter the following error message
    while collecting Services information and it just freezes up and never gives me
    a log

    'inst.PathName' is null or not an object

    I did some research on the error and I found this script
    ListOrphanservices.vbs that can pinpoint the services
    that are causing the problems and this is the log from that
    but I'm not sure how to go about correcting them...was hoping
    somebody here could walk me thru it. The 1st 2 services I have
    disabled because I no longer have that program on my pc anymore
    but Im not sure if they still need to be fixed....


    Services with missing ImagePath value
    --------------------------------------

    Service : AcrSch2Svc
    Display : AcrSch2Svc
    Image Path :

    Service : afcdpsrv
    Display : afcdpsrv
    Image Path :

    Service : WLSetupSvc
    Display : Windows Live Setup Service
    Image Path :


    Thanks so much!
     
  2. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
    The Image Paths are gone but the entries are probably still there in the registry. You'll need to delete them.

    Click Start > Run > type regedit

    Go to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AcrSch2Svc

    Right-click and delete AcrSch2Svc

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\afcdpsrv

    Right-click and delete afcdpsrv

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WLSetupSvc

    Right-click and delete WLSetupSvc
     
  3. MJT27

    MJT27 Thread Starter

    Joined:
    Feb 1, 2004
    Messages:
    159
    They were all there and I have deleted all of them...thanks so much for
    your help...that was the ticket...I can now view my running services!!!

    Appreciate your time!
     
  4. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
    You're welcome!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/910565

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice