1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Hi-Speed USB Host Controller not working.

Discussion in 'Hardware' started by TroyFalls, Dec 22, 2008.

Thread Status:
Not open for further replies.
  1. TroyFalls

    TroyFalls Thread Starter

    Joined:
    Nov 23, 2008
    Messages:
    1
    I have had occasional trouble with my hi-speed USB connection to an external hard drive - it is sometimes recognised as hi-speed, and sometimes not. It has now finally given up completely. When I go into the Device Manager, select the Standard Enhanced PCI to USB Host Controller, and go into Properties, I am told that the device cannot start (Code 10). When I have checked, I have been informed that my driver is up to date. I have sent the data to Microsoft for a possible solution, but have had no response. I would be grateful for any suggestions. Thank you.
     
  2. cpossamai

    cpossamai

    Joined:
    Dec 23, 2008
    Messages:
    13
    what was the solution please?
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/782319

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice