1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: HL2, Failed to lock Index/vertex buffer

Discussion in 'Games' started by Frippe92, Nov 8, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    hen i start the single player mission on Half life 2 i see the cinematic(with the elderly man talking) but when he tells me to wake up and i get control over my character the game crashes and it tells me that it failed to lock Index or vertex buffer( different from time to time),
    Portal and Team fortress 2 (other games i got with the Orange box) works without any problems but Half Life 2 crashes every time!

    i ran the Diagnostic tool and it says i got out of date Display drivers although i just used that very link to download and install the latest!

    it says i need atleast version 91.47 but I've got 163.75.
    Code:
    Results
     
     
    
    General System Performance: Passed 
    Your system meets the requirements for the Source games. 
    Your CPU: Intel 3058 MHz
    Minimum CPU: 1200 MHz
    Recommended CPU: 2400 MHz
    
    Total Memory: 1024 MB
    Available Memory: 475 MB
    Minimum Memory: 256 MB
    Recommended Memory: 512 MB
    
     
     
    
    Display drivers: Failed 
    Your nVidia display drivers are currently out of date
    For updated drivers, click here
    Display Adapter: NVIDIA GeForce 7300 GS
    Display Version: 6.14.11.6371
    Recommended Driver Version: 91.47 
    Recommended Driver Date: 09/01/2006
    Severity: Very High 
     
     
    
    DirectX: Passed 
    Your version of DirectX meets the minimum requirements
    
     
     
    
    UDP Ports: Passed 
    The following UDP ports were reachable. 
    UDP Port: 27000 - 27040 
    
     
     
    
    TCP Ports: Passed 
    The following TCP ports were reachable. 
    TCP Port: 27020 - 27040 
    
     
     
    
    Background Processes: Passed 
    There were no processes found that conflict with Steam or the games. 
     
     
    
    Loaded Modules: Passed 
    There were no loaded modules found that conflict with Steam or the games. 
     
     
    
    Services: Failed 
    The following services were found on your system. Please try disabling the service or uninstalling the application assoicated with them, and see if that resolves your issue 
    Service: Norton AntiVirus Firewall Monitor Service
    Norton AntiVirus Firewall is running. Make sure all required ports are open, and all instances of Steam.exe, hl.exe, and hl2.exe are allowed access to the internet.
    Severity: Very High 
     
     
    
    Layered Service Providers: Passed 
    There were no LSPs found that should conflict with Steam or the games. 
     
     
    
    Audio/Video Codecs: Passed 
    There were no audio/video codecs found that conflict with Steam or the games. 
     
     
    Possible Suggestions
    
    
    If Steam continues to crash, try deleting all files and folders in the Steam directory except for steam.exe and the SteamApps folder 
    
     
     
    
    If you continue to have problems playing the games, try using the launch options -nosound and -windowed. 
    
    Open Steam, then Play games
    Right click the Souce game, click properties, then Launch options
    add -nosound -windowed, click ok, then close. 
    
     
     
    
    If you continue to have problems updating Steam, please exit from Steam, and then delete the following files from your Steam directory. 
    
    C:\Program Files\Steam\Steam.dll
    C:\Program Files\Steam\SteamUI.dll
    C:\Program Files\Steam\ClientRegistry.Blob 
    
     
     
    
    If you continue to have problems finding any servers, please exit from Steam, and then delete the following files from your Steam\config directory. 
    
    C:\Program Files\Steam\config\serverbrowser.vdf
    C:\Program Files\Steam\config\masterservers.vdf 
    
     
     
    
    If you continue to have problems with your performance in game, try forcing a lower level DirectX version. Start at the lowest level and go up from there till you find a good level of FPS. 
    
    -dxlevel 70
    -dxlevel 80
    -dxlevel 81
    -dxlevel 90 
    
    -Open Steam, then Play games
    -Right click the Source game, click properties, then Launch options
    -add -dxlevel XX, click ok, then close 
     
  2. tom6049

    tom6049

    Joined:
    Aug 5, 2007
    Messages:
    775
    Hmmm...looks like you have 163.71 drivers....
    163.75 WHQL drivers did come out this past Tuesday (Nov.06).
     
  3. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    oh im sorry.. i didnt remember the exact number so i checked the site and though that number was familiar since i installed them so recently.. its still way higher that 91.47 though :confused:
     
  4. tom6049

    tom6049

    Joined:
    Aug 5, 2007
    Messages:
    775
  5. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    got version 163.75 now but i still get error message and the game crashes.. this time it said

    Engine error [X]
    Internal driver error in IDirect3DDevice9::present()
    [OK]
    Ps. i think i got that one before too
     
  6. tom6049

    tom6049

    Joined:
    Aug 5, 2007
    Messages:
    775
    The next step would be to make sure that the DirectX version is current.
    There is a November update for DirectX 9.0c
    If that doesn't help, you might want to check out the Steam forums.
     
  7. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    updated my directx now.. still gets
    Internal driver error in IDirect3DDevice9::present()
     
  8. tom6049

    tom6049

    Joined:
    Aug 5, 2007
    Messages:
    775
    Have you tried using a lower DirectX level?
    I suggest that you try -dxlevel 70 first.

    From the Steam support forums:
    1. Open Steam
    2. Go to the "My Games" tab
    3. Right-click the game which needs to be reconfigured
    4. Select "Properties" from the menu
    5. Click the "Set launch options..." button
    6. Add one of the DirectX level launch options specified below - be sure to include a space before the "-" and anything before it.


    DirectX Level Launch Options

    -dxlevel 90 (DirectX v9.0)
    -dxlevel 81 (DirectX v8.1)
    -dxlevel 80 (DirectX v8.0)
    -dxlevel 70 (DirectX v7.0)
     
  9. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    i tried level 70 and it worked!! its a miracle!
    the ammo bar seems a little bugged though...
    should i try the higher ones too until it stops working?
     
  10. tom6049

    tom6049

    Joined:
    Aug 5, 2007
    Messages:
    775
    I would....keep going up in DirectX levels until the crashing returns, then drop down one.
    The lower the DirectX level, the better the performance will be, so keep this in mind as well.
     
  11. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    ok.. so is there any downside in having lower level?
     
  12. Frippe92

    Frippe92 Thread Starter

    Joined:
    Nov 8, 2007
    Messages:
    12
    nr 70 worked but ammo bar was bugged
    nr 81 got the error after a while
    and 80 works perfect, thanks for all the help!
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/649464