1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: How do I change default hard drive when doing a "Save as""?

Discussion in 'Windows XP' started by hhannam, Mar 24, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    It's a mole hill of a problem, but it is a bit annoying to have to click on my principal drive ("C") every time I'm doing a "save". I have enclosed an excerpt of a screen shot of my "save as" window to display how the default drive being automatically selected is the "D" drive rather than the "C" drive that I use primarily. To be honest, I don't know whether this can be corrected by a software change, or whether it's the way the two hard drives are connected in my computer.

    I'd appreciate it if anyone has a suggestion to offer if there is a way to make my "C" drive the default selection when I attempt to do a save function. Thanks :confused:
     

    Attached Files:

  2. Sponsor

  3. DaveA

    DaveA Trusted Advisor

    Joined:
    Nov 16, 1999
    Messages:
    14,795
    First Name:
    David
    Depending on what program is being used at the time of this "Save As", some programs the "Default" location can be set within the program.

    But if you are "Right clicking" a file, from Windows Explorer, the in most cases it remembers where the last Save as location used is remembered.
     
  4. bjd417

    bjd417

    Joined:
    Mar 24, 2010
    Messages:
    21
    DaveA is right , for internet explorer, it can be modified

    To change the default folder to which Internet Explorer will save items, you must change the value for Personal in the following registry keys to specify the new location:
    HKEY_USERS\Default\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

    HKEY_USERS\Default\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell
     
  5. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick

    As mentioned in my initial post, I always change the selection to my "C" drive, but it never remembers that selection and automatically reverts to the "D" drive every time, no matter what source I am saving from.:(
     
  6. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    While I appreciate your telling me what changes to make in the registry, I have to admit my technical ignorance on how to go about modifying my registry. Unless I have step by step instructions I'm afraid I'll end up doing some kind of damage.:eek:
     
  7. bjd417

    bjd417

    Joined:
    Mar 24, 2010
    Messages:
    21
    ah i see,
    well first off go---> start, click run,type regedit (first attachment)
    then click the + sign on the following folders
    HKEY_USERS\Default\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    (it should look like the 2nd post screen shot)
    highlight Personal on the left,double click it,
    when the next box comes up, type in ------------> C:/ (3rd attachment)
    or where ever you want the default location to be,
    -------------------------------------
    this also needs to be done by clicking on the folder User Shell and repeating the last part (4th and 5th attachment), by editing the personal Registy file as well, pointing it to the same place of your liking,
    if i confused you on any part let me know.
     

    Attached Files:

  8. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    bjd417 - Thanks for the step by step instructions. I believe I followed them correctly, but I didn't understand the "attachment" references (third, and then, fourth and fifth). If that was supposed to be included in my registry changes somehow, then I did leave something out.

    In any event, I don't see any changes to the "save as" windows that still come up with the "D" drive highlighted when I try to save to "My computer", C drive from MS Wordpad, or Sun's Open Office Writer (word processor). Nor do I understand what was meant by saving in Internet Explorer. I use the Mozilla Firefox browser anyhow.
     
  9. throoper

    throoper Trusted Advisor

    Joined:
    Jan 20, 2007
    Messages:
    5,176
    Hi hhannam,

    I'm looking at the screenshot you attached and I'm confused.
    Do you mean when you click "Save as" the Save In location at the top of the Window is always My Computer?
    Or do you click the My Computer icon on the Places bar on the left to go there?

    T. :)

    Edit: If it's the latter, it's a simple fix.
     
  10. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    To Throoper: When the "Save as" window comes up I select the "My computer" icon on the left because I want to file whatever it is in the "C" drive (as opposed to "My documents, for instance) My screenshot, which is attached to my original post, shows that the "D" drive comes up highlighted in blue. Unless I then click on the "C" drive, "D" drive is where my file will be stored.

    Note: The "My computer" icon is missing from my screen shot because I only captured the upper section of the window in order to show the highlighted (default selected) "D" drive in the color blue (as opposed to black text for the rest).

    I hope I've clarified the issue but let me know in case I've only made it worse...ha! I truly do hope you have a solution, but if you don't, thanks for you help anyhow :D
     
  11. throoper

    throoper Trusted Advisor

    Joined:
    Jan 20, 2007
    Messages:
    5,176


    Perfectly clear (y)

    I have no idea why D:drive is highlighted and can't find a way to have C:drive selected instead. I suspect you're right about the way your configured.

    But there's a way to work-around the problem.
    You can change one of the 5 default buttons on the Places bar to open directly to C: or whatever folder you want. I would suggest Network Places as I don't know anyone who uses that location to save to.
    It's a very simple edit in the Registry or you can download TweakUI and use that to make the change.
    It's your choice. If you want to give the Registry edit a go, I'll post step by step instructions. Just let me know which button you want for C:

    T. :)
     
  12. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    throoper- I already have TweakUI downloaded, so I guess you can forward your step by steps again. I'm really queasy about messing with the registry, so I'm depending on the fact that you know what you're doing. If you have any doubts, don't hesitate to say so. Thanks
     
  13. throoper

    throoper Trusted Advisor

    Joined:
    Jan 20, 2007
    Messages:
    5,176
    In TweakUI, expand "Common Dialogs" by clicking the plus sign.
    Click "Places Bar" to display the settings dialog in the right pane.
    Place a check in "Custom Places Bar".
    Either use the drop downs to select the preset location for each button or type the complete path to the desired location.
    For example: If you wish to replace Network Places with C: all you need do is type C:\ on that line.
    Click OK to close TweakUI and save the change and the new button will show on the "Save as" next time you open it.

    That will save you messing in the Registry.

    Let me know if that does it for you.

    T. :)
     
  14. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    Well, the problem is solved......sorta...ha! Using TweakUI, I've changed the assortment of icons in my "Save As" window so that I can make one click on the "C" drive, for instance, without having to select "My Computer" first and then select the "C" drive secondly. So from a practical standpoint you've solved my problem, but when I click on "My Computer", either in the "Save As" window or in the Start menu, I still get a window with the "D" drive highlighted in blue, and not the "C" drive. This isn't a major issue by any standard, so I'm very thankful for your help and improvement with my annoying little item. It will make the saving selection one step simpler.

    I've attached a couple more screen snapshots to display what I'm referring to, but I'm going to go ahead and mark this post as "Solved", thanks to you. If you'd like to make any final comments, I'd be glad to hear from you. Thanks ever so much again ...(y)(y)(y)(y)(y):D:D:D:D:D:D:D:D:D:D:D
     

    Attached Files:

  15. hhannam

    hhannam Thread Starter

    Joined:
    May 23, 2005
    Messages:
    481
    First Name:
    Dick
    Just that quickly I forgot to include the snapshot of the "My Computer" window (from clicking on My computer posted in the "Start" window) that also has the "D" drive highlighted in blue
     

    Attached Files:

  16. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    It blue because you've enabled NTFS compression on the drive.

    Unless you really need the space (which I assume you don't as the drive is 74.59% free), you should disable compression. It does incur a slight performance penalty, and makes files much harder to recover if that becomes necessary.

    In My Computer, right click the drive, click Properties
    Uncheck the box for Compress drive to save disk space
    Click OK
    You'll get a confirmation dialog
    Check the option Apply changes to D:\, subfolders and files and click OK
    This could take several minutes
    You may need to defragment the drive when it completes.
     
  17. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved change default
  1. michael1129
    Replies:
    8
    Views:
    529
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/912279

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice