1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: How do I stop all external drives from being "found" every time I boot?

Discussion in 'Windows 7' started by bj nick, Nov 23, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. bj nick

    bj nick Thread Starter

    Joined:
    Jun 10, 1999
    Messages:
    1,816
    I have three external drives, and every time I boot now, they show up as "found," as if I'd just put in a USB drive.....meaning I have to close them all each and every time. Not a serious issue, just an annoyance I'd like to avoid. How can I set it so that they are not "found" each time?
     
  2. geek-assist

    geek-assist

    Joined:
    Oct 4, 2011
    Messages:
    27
    can you tell us at what stage of the boot process do you find it? and can you tell us the exact message that you get? and where exactly do you get this?
    thanks, this would help me understand better
     
  3. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    You can turn off autoplay completely in Control Panel.

    But if you look at the properties of those drives in Device Manager, you might see that caching is turned off ("performance" settings). If you turn that on for those drives, not only will they perform better, but the OS will then tend to regard them as more "permanent" and may stop opening that dialog each time.
     
  4. bj nick

    bj nick Thread Starter

    Joined:
    Jun 10, 1999
    Messages:
    1,816
    Hi, thanks for the responses. I should have clarified: it's the auto-play screen/menu that comes on. I shut off the global enabler option, and also set the drives for write-caching. As far as I can tell, the only "downside" is that I would have to use the "safely remove hardware" icon process....which is no big deal.
     
  5. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Did it help?

    Are these onboard USB ports or on a PCI card?

    (I use Safely Remove with all drives, anyway, even if not using a cache. I just don't want to take the chance, especially with SATA hard drives.)
     
  6. bj nick

    bj nick Thread Starter

    Joined:
    Jun 10, 1999
    Messages:
    1,816
    Elvandil, thank you for caring to follow up......much appreciated.

    I just changed the auto-play settings and that was that. RESOLVED!
     
  7. Elvandil

    Elvandil

    Joined:
    Aug 1, 2003
    Messages:
    51,988
    Good work. :D
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1028085

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice