1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: ICS between XP and Vista

Discussion in 'Networking' started by xemplary, Sep 19, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. xemplary

    xemplary Thread Starter

    Joined:
    Jan 13, 2007
    Messages:
    10
    I did a search and found a similar issue but it was expired.
    I have a desktop running XP Pro SP2:
    - connected to a cable modem via a Realtek network card (set ICS on this one)
    - instaled a LevelOne USB wireless adapter (set Ad Hoc connection with WEP)

    And I have a laptop with Vista Home Premium:
    - Ad Hoc connection set - can share files with XP, no problem
    - can not access the internet < MY PROBLEM

    Any help would be appreciated.

    Details:

    XP
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Mexican>ipconfig -all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : mex
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Cable:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
    rnet NIC
    Physical Address. . . . . . . . . : 00-50-FC-6B-F1-5B
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 82.192.43.132
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 82.192.43.1
    DHCP Server . . . . . . . . . . . : 213.143.64.118
    DNS Servers . . . . . . . . . . . : 213.143.65.11
    213.143.65.12
    Lease Obtained. . . . . . . . . . : 19. september 2008 23:59:34
    Lease Expires . . . . . . . . . . : 20. september 2008 1:39:34

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 11g Wireless USB Adapter #2
    Physical Address. . . . . . . . . : 00-11-6B-19-F6-FB
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

    Vista
    Microsoft Windows [Version 6.0.6000]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\Mihalj>ipconfig -all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Mihalj-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Dell Wireless 1490 Dual Band WLAN Mini-Ca
    rd
    Physical Address. . . . . . . . . : 00-1F-E1-23-97-63
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::6844:b94:fa04:30f7%10(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : lcj.emea.dell.com
    Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controlle
    r
    Physical Address. . . . . . . . . : 00-1D-09-D6-50-57
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 6:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.lcj.emea.dell.com
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 10:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{2BBC25D9-AAE9-41D5-896A-14641DE3E
    E19}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.2%14(Preferred)
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Disabled

    C:\Users\Mihalj>
     
  2. ~Candy~

    ~Candy~ Retired Administrator

    Joined:
    Jan 27, 2001
    Messages:
    103,706
    If you can share files, and not access the internet, my best guess is a firewall of some type.
     
  3. Wanderer2

    Wanderer2

    Joined:
    Jan 28, 2008
    Messages:
    1,428
    I would agree. Your ip settings are correct. See if you can ping between ips.
     
  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    79,594
    First Name:
    Terry
    Wanderer2, look at that IP configuration again! :)

    The easiest fix is to change the wireless connnection on the Vista to 'obtain IP auto' and 'obtain DNS auto.' Else set the ipv4 DNS to 192.168.0.1.
     
  5. xemplary

    xemplary Thread Starter

    Joined:
    Jan 13, 2007
    Messages:
    10
    sorry, I forgot to mention my ZoneAlarm Pro firewall. I've made a search in Google for ICS issues with ZA and found this note - on the "To configure for ICS" part.
    It helped me to properly set ZA for ICS on my XP machine.

    For a few seconds there was a Vista - internet connection, but no pages could be displayed. Then lost it again.

    Then I've set the ipv4 DNS to 192.168.0.1 and after a moment the internet connection was back and the pages - Google was the first :rolleyes: - rolled in.

    Thanx to all for the tips. I knew it was something plain and simple. :eek:
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/751481

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice