1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: IE Won't Open When Clicking on Hyperlinks

Discussion in 'Archive: Web & Email' started by Scriptoe, Jul 16, 2004.

Thread Status:
Not open for further replies.
Advertisement
  1. Scriptoe

    Scriptoe Thread Starter

    Joined:
    Jul 16, 2004
    Messages:
    18
    Let me start off by saying hello, I'm obviously new here. But not new to pc's at all. This is a very interesting looking forum and I hope I can contribute.

    I am having a strange but probably simple problem which just started. I'm running XP pro on cable modem and use IE and Outlook. (please no more debates about browser and email prefferences :) )

    The problem is that links that appear in programs such as Outlook, Newsleecher, even MSN messenger, won't open up the browser and go to the page. The little hand appears in the mouse pointer but when I click nothing happens. Of course before the browser (IE) would open on the correct page whenever I clicked such a link. The problem is not confined to the programs I listed, it is global. No matter what program I have open, if there is a web link displayed within it, it will not open IE and go to the page like it's supposed to.

    I have checked my firewall, virus software and spyware blockers and they dont' seem to be causing the problem. I install and uninstall new software all the time and it's very possible a simple setting got changed somewhere. But for the life of me I can't find it.

    Any insight would be greatly appreciated.

    Thanks guys.
     
  2. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,942
    It could be caused by an unregistered .dll file. Try this and let us know what happens ...

    Close all programs

    Click on Start>Run, key in the following and press enter

    regsvr32 urlmon.dll

    Click on OK when you receive the completion message.

    If that doesn't resolve it, try the same command with the following files

    Shdocvw.dll
    Msjava.dll
    Actxprxy.dll
    Oleaut32.dll
    Mshtml.dll
    Browseui.dll
    Shell32.dll
     
  3. Scriptoe

    Scriptoe Thread Starter

    Joined:
    Jul 16, 2004
    Messages:
    18
    Interesting thing to try, I didnt' think of it. However it had no effect.

    I recently installed a bunch of new browsers so I could try them out but ended up deleting them. I'm thinking one of those may have changed a setting somewhere that I can't find. I do have IE set to my default browser. and I have looked through all the internet advanced options, folder options and file associations.

    This is a very hard problem to search for in google mainly because no matter how I word it I get a bunch of stuff that has nothing to do with what I want.

    Anyway, keep the good ideas coming, we're getting closer. :) :)
     
  4. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,942
    Try checking the file association for "NONE: URL HyperText Transfer Protocol"

    Goto the Control Panel and click on FolderOptions. Then click on File Types. Scroll down and locate the above file type and click on Advanced then Edit. Now compare the values to the ones listed at the link below ...

    http://www.oehelp.com/ielnk.aspx
     
  5. Scriptoe

    Scriptoe Thread Starter

    Joined:
    Jul 16, 2004
    Messages:
    18
    I just noticed a new twist. Even when I have a software of any kind open and I go to somewhere in the menu such as help/support or anywhere that's supposed to open up a website for you, it doesn't happen. The only way I can open my browser is to click on the shortcut or the exe file. Nothing else will open it for me.

    What gives?
     
  6. Scriptoe

    Scriptoe Thread Starter

    Joined:
    Jul 16, 2004
    Messages:
    18
    Genious!!

    That was the problem. They were set to Opera browser.

    Yet another reason to not use that browser.

    Thanks a million sir. :)
     
  7. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,942
    Your welcome, glad to hear you're ok now ...
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/251196