1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Jumpy Mouse

Discussion in 'Windows Vista' started by thundercraft, Apr 1, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. thundercraft

    thundercraft Thread Starter

    Joined:
    Feb 13, 2009
    Messages:
    49
    Hello,

    I have just recently developed a very jumpy mouse! When I go to drag an email into a folder it takes several attempts to make it work. It keeps getting dropped or ends up on the task bar?

    Also when I try to highlight a line of text to delete or make corrections the highlight jumps all over the place or when I let go of the left button the highlight disappears? This happens everywhere.m in the pas
    At first I though there might be a bug in the computer but I have tried several scans with "Malware Bytes" an nothing shows up. I use "Avast" for virus protection and the scans are clean. The mouse is a Logitech Wireless and it has never been a problem in the past. I though the problem might be relegated to just my email program "Windows Mail" but it is showing up everywhere?

    I am running Vista (32) and Firefox Ver 3.6.2

    Has anyone ever experienced this. Would appreciate your help on trying to correct:confused:

    Thanking you in advance.
     
  2. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    Have you replaced the battery?
     
  3. thundercraft

    thundercraft Thread Starter

    Joined:
    Feb 13, 2009
    Messages:
    49
    Yes I have!
     
  4. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
    Did you change mouse pads? Tried another one? Is there any lint or gunk build up on the bottom, does it drag easily?
     
  5. thundercraft

    thundercraft Thread Starter

    Joined:
    Feb 13, 2009
    Messages:
    49
    No I have not tried that but I will and let you know.
     
  6. thundercraft

    thundercraft Thread Starter

    Joined:
    Feb 13, 2009
    Messages:
    49
    Hi Guys,

    Thanks for your input. Seems to now be working okay! New battery, new mouse pad and I cleaned the bottom of the mouse.

    Thanks again!
     
  7. Bernardo

    Bernardo

    Joined:
    Jan 8, 2006
    Messages:
    4,221
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/914132

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice