1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Limited Connectivity

Discussion in 'Networking' started by yonyz, Sep 30, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. yonyz

    yonyz Thread Starter

    Joined:
    Aug 7, 2008
    Messages:
    341
    Hi,

    Yesterday I've moved to Vista, and I couldn't connect to the router with my Wireless Network USB adapter.

    When I was using XP, there was an option called "Internet Protocol (TCP/IP)",
    and in Vista there are only "Internet Protocol Version 4 (TCP/IPv4)" and "Internet Protocol Version 6 (TCP/IPv6)".

    So I set the correct IP and DNS server settings in the V4 properties, but I get limited connectivy,
    and there's no access to the internet at all.

    I also chose Open authentication and set the correct password just as it is configured in my ASUS AM 604g router.

    When trying to connect to the network, it says "Connecting to the network is taking longer than usual".

    Then there are messages like "Identifying", "Connected with limited access", etc..

    My brother have set all things up when I was using XP, but he is not home right now, and my knowledge about networks is very limited.
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    First off, IPv4 is the TCP/IP that you'll be connecting with, it's the same as XP.

    Try a couple of things.

    Try connecting the Vista machine with a wired connection to see if this is just a wireless issue, or something more general.


    Try removing ALL encryption and MAC filtering from the router to see if you can connect that way. Many times, this is an encryption key mismatch or MAC address mismatch.



    Next, we can try a stack repair.

    TCP/IP stack repair options for use with Windows Vista.

    Start, Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

    In the command prompt window that opens, type type the following commands:

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

    Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

    Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

    Reboot the machine.




    If you still can't connect, here are some compatibility settings for Vista.

    Changes that may help to increase the compatibility of Vista with older networking devices:



    Disable the IP Helper service:

    1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
    2. Scroll down to the IP Helper service, right click on it and select Properties
    3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
    4. Then click on "Stop" to stop the service from running in the current session
    5. Click OK to exit the dialog



    Disable IPv6:

    1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
    2. Right click on each network connection and select "Properties"
    3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
    4. Click OK to exit the dialog

    NOTE: You should do this for each network connection.



    Disable the DHCP Broadcast Flag:

    Link: http://support.microsoft.com/default.aspx/kb/928233
    1. Hold the Windows key and type R, enter regedit and press Enter.
    2. Locate and then click the following registry subkey:
    3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
    4. In this registry path, click the (GUID) subkey to be updated.
    5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
    6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
    7. In the Value data box, type 0, and then click OK.
    8. Close Registry Editor.
    NOTE: You should do this for each and every GUID subkey.
    NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




    The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.






    Finally, I'd like to see this for the machine if you still aren't connecting.

    Hold the Windows key and press R, then type CMD to open a command prompt:

    In the command prompt window that opens, type type the following command:

    Note that there is a space before the /ALL, but there is NOT a space after the / in the following command.

    IPCONFIG /ALL

    Right click in the command window and choose Select All, then hit Enter.
    Paste the results in a message here.

    If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
     
  3. yonyz

    yonyz Thread Starter

    Joined:
    Aug 7, 2008
    Messages:
    341
    OK, I disabled both MAC filtering and WEP encryption, and it works.
    I'm now typing from the Vista machine.

    I probably should not keep it that way.
    What can I do to make it work with the WEP encryption?

    --Update--

    Well, I just changed the WEP encryption password to a numbers only-password, and it works fine.

    Thank you, John.
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Well, why not use WPA instead of WEP, it's much more secure? In addition, there are some issues with certain adapters and drivers with Vista using WEP anyway.
     
  5. yonyz

    yonyz Thread Starter

    Joined:
    Aug 7, 2008
    Messages:
    341
    I think that WEP is secure enough.
    Also, when choosing WPA as the type of encryption, it shows
    many more settings to be set for the encryption.

    That's beyond my knowledge of networking, but I may ask my brother to do that for me.

    So thank you again, John.
     
  6. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Actually, WEP is not secure at all, but it's your network. ;)

    I don't know what is so complicated, how about posting a screen shot of your router's WPA setup and we'll show you the way? :)
     
  7. yonyz

    yonyz Thread Starter

    Joined:
    Aug 7, 2008
    Messages:
    341
    I just asked my brother, and he says that the encryption doesn't really matter,
    because you can't gain access to the router without the exact same machine ID.

    Does this make any sense? :D
     
  8. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    None at all. Your brother, sad to say, doesn't know what he's talking about. :)
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Limited Connectivity
  1. Renegade70
    Replies:
    1
    Views:
    443
  2. highenough
    Replies:
    3
    Views:
    524
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/754760

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice