1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Matshita UJ 845s PIO mode only

Discussion in 'Hardware' started by dustyjay, Jan 25, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. dustyjay

    dustyjay Thread Starter

    Joined:
    Jan 23, 2003
    Messages:
    12,661
    First Name:
    Jay
    I have a Toshiba Satellite A105-S2231 Notebook. THe Optical drive is a Matshita (Panasonic) UJ 845S DVD-Ram writer. It is extremely slow as it is running in PIO mode. DMA if Available is enabled but it still operates in PIO mode. There is no where in the bios to change this. I have tried changing it in Device Manager. It says the IDE Channel it is attached to is set to DMA if available. Yet it still nsays the Transfer rate is set to PIO. I Can not locate the Firmware version of this drive or its driver dates. Can any one suggest where to look or to find it?

    EDIT: After removing the drive from the laptop it has the Model Number on it of UJ 850. I can find no reference to it in the Matshita (Panasonic) Site. Device Manager identifies it as a UJ 845S as does Everest Home.
     
  2. dustyjay

    dustyjay Thread Starter

    Joined:
    Jan 23, 2003
    Messages:
    12,661
    First Name:
    Jay
  3. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Try this randance.

    Set the drive to PIO mode in device manager.

    Reboot.

    Enter the BIOS setup and set the channel to PIO mode.

    Let Windows boot.

    Set the drive to DMA If Available.

    Reboot.

    Enter the BIOS setup mode and set the drive to automatic mode.

    Let tje system reboot.

    See if that helps.

    I had a MB with W2K that would periodically drop into PI(O mode, and that was the only way to get it back into DMA mode.
     
  4. dustyjay

    dustyjay Thread Starter

    Joined:
    Jan 23, 2003
    Messages:
    12,661
    First Name:
    Jay
    I set the controllers to PIO mode then rebooted. I then set the controllers to DMA if Available mode and rebooted. Both controllers show DMA if Available. THe Controller for the hard drive is showing DMA 5 mode. THe Controller for the DVD Ram Drive still shows that the transfer mode is still PIO. DMA if Available is still set for it. There is no place in BIOS to set the Drives to Automatic. THe drive show up on the setup screen but are not available for settings changes. IN the Boot setup screen the only things that can be changed is the boot order. Transfer speed for this drive is seriously slow. Some DVD movies are even affected by this. Is this normal for a dvd ram drive? Is this maybe something that a bios update will repair. I can find no reference to this problem on the TOSHIBA Site
     
  5. norton850

    norton850

    Joined:
    Mar 8, 2004
    Messages:
    7,794
    Uninstall secondary IDE channel and reboot?
    Bad drive?
     
  6. dustyjay

    dustyjay Thread Starter

    Joined:
    Jan 23, 2003
    Messages:
    12,661
    First Name:
    Jay
    :D Drive is good but not the best drive I have ever used. Uninstalling the Secondary Controller in Device Manager then rebooting did the trick though. Confused me completely but it is solved. I hope thaqt if anyone else has problems with thier Satellite like this it will help them. THis is an A105-S2231. I think I am going to go find a better drive that will fit this Laptop. So this is marked as solved thank you for your help and effort.:D
     
  7. stoical

    stoical

    Joined:
    Jan 28, 2007
    Messages:
    1
    This tip comes from the Sniptools web site, and it has worked for on several ocasions, all due to failures to read discs (damaged, dirty or in DVD Decrypter trying to rip DVDs with error sectors for copyright ---ones I own!!)

    CD-ROM and DVD-ROM drives can revert to using PIO mode, despite being set to use "DMA if Available." Here's how to make Windows XP redetect the DMA capabilities of the drives.
    This behaviour occurs with the following conditions:

    Windows XP is the operating system
    A CD-ROM or DVD-ROM drive, which is known to support DMA mode now works only in PIO mode.
    The drive controller is set to use "DMA if available" but reports to be only in PIO mode.
    Following is the mechanism that has worked for me, please try it at your own risk, it involves hacking the registry:

    Open RegEdit
    Find the following KEY:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x
    The last four digits will be 0000, 0001, 0002, 0003, and so on.
    Under each key, delete all occurences of the following values:
    MasterIdDataChecksum
    SlaveIdDataChecksum
    Reboot the computer. Windows will now redetect DMA settings.
    Trala!
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/538372

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice