1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

[SOLVED] McAfee Firewall Communication Alert

Discussion in 'All Other Software' started by gillcy, Sep 10, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. gillcy

    gillcy Thread Starter

    Joined:
    Jan 17, 2003
    Messages:
    34
    I am not sure this is the right forum, but here goes. I am having problems with a McAfee Firewall Communication Alert. It pops up every time I log on. At the top it says Application Layer Gateway Service v5.1.2600.1106
    Then it states that "This program C:\\WINDOWS\SYSTEM32\ALG.EXE is trying to access the INTERNET. Do you want to allow it? How do I stop this from popping up. I went to the Firewall and allowed it. It still pops up. Any advice would be appreciated. It started after I updated Windows.
    :confused:
     

    Attached Files:

  2. cybertech

    cybertech Retired Moderator

    Joined:
    Apr 16, 2002
    Messages:
    72,115
    quote from pcmag.com

    FILENAME: Alg.exe.
    PROGRAM NAME: Application Layer Gateway.
    DESCRIPTION: Part of Windows XP that provides support for ICS and Internet Connection Firewall (ICF).
    RECOMMENDED ACTION: If a third-party firewall warns you that ALG.exe wants access, check to make sure you're not double-firewalled. If you are, disable ICF. If you are using neither ICF nor ICS and are warned that ALG.exe is trying to access the Net, deny it. A Trojan horse or worm may be trying to use it as a backdoor.


    Looks like you don't need that since you are using McAfee Firewall.
     
  3. gillcy

    gillcy Thread Starter

    Joined:
    Jan 17, 2003
    Messages:
    34
    Thanks! Where do I go to disable ICF or ICS?
     
  4. BillC

    BillC

    Joined:
    May 28, 2003
    Messages:
    2,366
    In XP, ICF is found Start > Control Panel > Administration Tools > Services > Application Layer Gateway Service. Disable the Application Layer services.
     
  5. gillcy

    gillcy Thread Starter

    Joined:
    Jan 17, 2003
    Messages:
    34
    Thanks for the quick reply!
     
  6. gillcy

    gillcy Thread Starter

    Joined:
    Jan 17, 2003
    Messages:
    34
    This solved the problem. I disabled the Application Layer Services.
    Thanks so much.
     
  7. cybertech

    cybertech Retired Moderator

    Joined:
    Apr 16, 2002
    Messages:
    72,115
    Thanks for letting us know :)
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - [SOLVED] McAfee Firewall
  1. DaveA
    Replies:
    6
    Views:
    365
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/163752

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice