1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Memory Controller problem

Discussion in 'Windows 7' started by kittenkitten, Mar 18, 2015.

Thread Status:
Not open for further replies.
  1. kittenkitten

    kittenkitten Thread Starter

    Joined:
    Aug 25, 2013
    Messages:
    69
    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft Windows 7 Professional, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM)2 Duo CPU P9600 @ 2.53GHz, Intel64 Family 6 Model 23 Stepping 10
    Processor Count: 2
    RAM: 3992 Mb
    Graphics Card: Mobile Intel(R) 4 Series Express Chipset Family, 1772 Mb
    Hard Drives: C: Total - 226772 MB, Free - 143182 MB; Q: Total - 10500 MB, Free - 4036 MB;
    Motherboard: LENOVO, 2801CTO
    Antivirus: Microsoft Security Essentials, Updated and Enabled



    Hello again. You guys and gals are always the first place I turn when we have problems with our computer. I hope you can help us once more.

    In devices and printers there was a picture of my laptop with a '!' on it. I ran the troubleshooter and it said there was a problem detected with 'Intel(R) Turbo Memory Controller' and for more information to open device property page. It said under 'device status' "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)"
    I tried to update the driver, but it said "Windows has determined the driver software for your device is up to date."
    Then the troubleshooter said it made some changes to the system, and to try attempting the task you were
    trying before. But, under problems found, it still says the 'memory controller is not working properly.' Also the still is an '!' on the picture of the laptop.

    What should we do now? The computer does seem slow. We put another user on it recently and had to remove it because it became extremely slow and erractic.

    Thank you for any suggestions you can give us.
    K. Kitten
     
  2. Golden_

    Golden_

    Joined:
    Mar 31, 2014
    Messages:
    364
    Hello,

    This webpage should have the drivers for Intel Turbo Memory: http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t400s/2801/cto/downloads/DS001676


    Try downloading that, then the executable should install the drivers necessary for your Memory Controller. After doing this, restart your computer and confirm if the driver in device-manager installed properly.

    The list of other drivers for your laptop can also be found here: http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-t-series-laptops/thinkpad-t400s/2801/cto
     
  3. kittenkitten

    kittenkitten Thread Starter

    Joined:
    Aug 25, 2013
    Messages:
    69
    Thank you, that did the trick!
    Best Regards,
    K.Kitten
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Memory Controller
  1. ozegirl
    Replies:
    10
    Views:
    2,312
  2. oldguy001
    Replies:
    6
    Views:
    253
  3. badengon
    Replies:
    2
    Views:
    227
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1145033

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice