1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Msiexec.exe bad image

Discussion in 'Windows 7' started by Mattrje, May 24, 2015.

Thread Status:
Not open for further replies.
Advertisement
  1. Mattrje

    Mattrje Thread Starter

    Joined:
    May 24, 2015
    Messages:
    4
    Hi,

    Recently when I install or try to update programs I've been getting errors relating to Windows installer, particularly "Msiexec.exe Bad image" error and internal program errors when updating saying "Windows installer service could not be accessed". I'm not sure of the exact time when it began happening but it would of been possibly a month ago.

    I've tried various fixes I've found online but nothing seems to fix it. Also, my msi.dll file in system32 contains 0kb.

    I've also tried doing windows repair and non-destructive windows installs but due to it being a windows installer problem I can't actually do the install.

    Any information regarding this problem would be incredibly helpful.

    Thanks
     
  2. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,615
  3. Mattrje

    Mattrje Thread Starter

    Joined:
    May 24, 2015
    Messages:
    4
    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz, Intel64 Family 6 Model 58 Stepping 9
    Processor Count: 4
    RAM: 8086 Mb
    Graphics Card: Intel(R) HD Graphics 4000, -1984 Mb
    Hard Drives: C: Total - 953765 MB, Free - 453467 MB;
    Motherboard: Gigabyte Technology Co., Ltd., Z77M-D3H
    Antivirus: AVG AntiVirus Free Edition 2015, Not Updated
     
  4. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,615
  5. Mattrje

    Mattrje Thread Starter

    Joined:
    May 24, 2015
    Messages:
    4
    Hi Lance1,

    When entering the first command line "%windir%\system32\msiexec.exe /unregister" I get the Msiexec.exe Bad image error, aswell as the /regserver.

    Although, this error does not come up with the "syswow64" commands.
     
  6. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,615
  7. Mattrje

    Mattrje Thread Starter

    Joined:
    May 24, 2015
    Messages:
    4
    Yes that worked!

    Thanks a lot for your help Lance!
     
  8. Lance1

    Lance1

    Joined:
    Aug 4, 2003
    Messages:
    5,615
    Your most welcome.
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Msiexec image
  1. ozegirl
    Replies:
    10
    Views:
    2,336
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1148725

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice