Solved: Need Audio Drivers For XP

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

madmin

Thread Starter
Joined
Nov 20, 2011
Messages
14
I wiped Vista and clean installed XP. I need an XP version of the audio drivers for the Sigmatel device that comes on the Emachines T3604 motherboard. I went on the Emachines website, and the only drivers there were for Vista, as it was the originally installed OS. I also asked two live support agents, and they cannot help because they say they have no XP drivers in their database.

At first, I accidentally installed the vista drivers and I got sound, but when I went to the Sigmatel option in control panel, it said "Unable to connect to COM interface." And when I added the volume icon to taskbar, I would turn the volume up or down and it would make the beep noise like when you don't have an audio device installed. I uninstalled the vista drivers and have been looking for an XP version.

I will be your best friend if you find the seemingly nonexistent drivers I'm looking for.




Tech Support Guy System Info Utility version 1.0.0.2
OS Version: Microsoft Windows XP Professional, Service Pack 3, 32 bit
Processor: Intel(R) Celeron(R) D CPU 3.33GHz, x86 Family 15 Model 6 Stepping 5
Processor Count: 1
RAM: 2GB
Graphics Card: ATI Radeon X1050, 256 Mb
Hard Drives: C: Total - 95001 MB, Free - 86030 MB;
Motherboard: Intel Corporation, D945GCL
Antivirus: Avast Free
 

madmin

Thread Starter
Joined
Nov 20, 2011
Messages
14
You have the Sigmatel HD Audio Driver (integrated sound card) on your system system. E-machine website doesn't show any drivers for xp for that model anymore because it only comes with vista. This same chipset is used by gateway and they have XP drivers: http://support.gateway.com/support/drivers/getFile.asp?id=20706&dscr=SigmaTel%20HD%20Audio%20Driver%20Version:%20%205.10.4647.4&uid=208846466
Thanks for replying. I ended up using Driver Genius to install a driver called IDT; I think thats who Sigmatel is.
I still had a beeping noise when changing the volume, but I got rid of that through the registry.
 
Joined
Oct 20, 2011
Messages
684
Yeah it's hard to find the Sigmatel driver for your version since the E-machine website doesn't show the xp drivers. The IDT driver is the same as the ones used on the gateway model link I gave to you if you ever need to save the drivers. Glad to help :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top