1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Need help setting up network

Discussion in 'Networking' started by deg2007, Feb 17, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. deg2007

    deg2007 Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    4
    I have two desktop PC's. The first is DELL8400 and is connected to a Linksys WRT54G router by ethernet cable. The other is L800 and is connected to the router by a wireless Linksys WUSB54GC adapter. Both desktops can get out to the internet just fine.
    From the DELL8400 I can ping both the IP address and the name (L800) of the other PC. But I can't see it when I go to "view workgroup computers", only the DELL8400 shows up.

    From the L800 I can ping the IP address but not the name (DELL8400) of the other PC. I can see the DELL8400 when I go to "view workgroup computers". When I click on the DELL8400 I get a message

    "\\Dell8400 is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permission.

    The network path was not found"

    Also, I can see the printer on the DELL8400 from the L800 but it will not print to it. Both PC's have WinXP home SP2. I've run the networking wizard on both. I've turned off the Windows Firewall. I have Norton AV but I've disabled it also. The only other thing that is kind of strange is that when I first boot up the DELL8400 I get a router login window asking for a user name and password. If I "Cancel" it keeps coming back. I leave the user name blank and enter my router password and it goes away. If I click "remember my password" it doesn't matter and still comes back.

    Any ideas on how I can get these two PC's talking?

    Thanks.
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    TCP/IP stack repair options for use with Windows XP with SP2.

    For these commands, Start, Run, CMD to open a command prompt.

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

    Reset TCP/IP stack to installation defaults. netsh int ip reset reset.log

    If that doesn't help, try this checklist:

    Checklist for networking Windows Machines with TCP/IP
    -----------------------------------------------------
    - PCs which are not XP must have TCP/IP installed.
    - Each PC must have a unique computer name.
    - Each PC must have a network share defined.
    - ALL NICS must be on the same subnet (e.g. IP 192.168.0.* subnet mask 255.255.255.0).
    - XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
    - MS Client and file & printer sharing must be enabled on each machine.
    - All NICs must have their node type = anything except p-node (peer to peer, or point-point).
    * To check, open a command prompt and type IPCONFIG /ALL.
    - XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2).
    - All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
    - PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).

    Allow 15 mins after rebooting a PC for that PC to appear in the workgroup, or
    for it to see all other PCs. Or you can search for the PC by its computer name.


    Additional things to check if you still have problems:
    -----------------------------------------------------
    - Check your Services are Started on all PCs: Workstation, DHCP Client, Server, TCP/IP Netbios helper, Computer Browser.
    - XP gives access to its shares via the Net Guest Account. (Note, not the same as the local guest account in user accounts which should be off). Net Guest Account is enabled by default in XP, but to check it, open a command prompt and type: NET USER GUEST
    Should return a line with 'Account active yes'.


    Check XP Security policies:
    --------------------------
    - Access this computer from the network: add guest
    - Deny logon locally: remove guest
    - Network access:Sharing and security model... -> Guest only
    - Deny access to this computer from the network-> check Guest is not here.
     
  3. deg2007

    deg2007 Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    4
    I did the first 2 commands with no change. Other comments in the checklists:

     
  4. deg2007

    deg2007 Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    4
    OK, so I unchecked all the firewall check boxes on the router and now I can connect the two PC's and the printer. The boxes I unchecked are: "Block Anonymous Internet Requests", "Filter Multicast", "Filter Internet NAT Dedirection", "Filter IDENT (Port 113)".

    So now my question is how can I be sure my system is secured. I though hardware firewalls were better than the software kind. What do I need to do so make my two PC's secure.

    Thanks.
     
  5. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    I'm totally confused, since none of those settings should have any effect on networking machines on your network. All of those options are for routing from/to the Internet to machines on your network.

    I suspect it's just a coincidence that it started working at the same time.
     
  6. deg2007

    deg2007 Thread Starter

    Joined:
    Feb 17, 2007
    Messages:
    4
    I turned the router firewall back on and I can still connect to the other PC, so you were right that it was just a coincidence. I also think part of my problem was that the remote PC was also set to go into hibernate mode, I turned this off. Thanks for your help.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/544805

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice