1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Network card can't detect crossover cable

Discussion in 'Networking' started by Agile, Jan 11, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. Agile

    Agile Thread Starter

    Joined:
    Jan 6, 2010
    Messages:
    24
    Hello,

    Im running windows xp on two different computers (a PC and a laptop) and for some reason when i plug in the crossover network cable, neither my laptop or my PC can see it. It just says that a network cable is unplugged. This is strange because if I connect a non cross over one (regular cat5) it sees it just fine.

    any ideas why this might be happening? the cable is brand new.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,169
    First Name:
    Terry
    Even new cables are sometimes defective.

    If either NIC is auto-sensing (most in the last few years are) the straight cable should work fine.
     
  3. Agile

    Agile Thread Starter

    Joined:
    Jan 6, 2010
    Messages:
    24
    Thats true it might be defective.

    How would i check if it is auto sensing or not?

    A straight cable before gave me the issue of limited connectivity, but I never checked any of the auto sensing features.

    what Im trying to do overall is connect the PC to the laptop to share the laptops wireless connection. I was under the impression I needed a crossover cable for this...am I wrong?
     
  4. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    If either of the machines has a gigabit Ethernet port, they are auto-MDX by definition.
     
  5. prunejuice

    prunejuice

    Joined:
    Apr 2, 2002
    Messages:
    3,432
    That's interesting. How does that work?
     
  6. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Nature of the beast. Gigabit uses all 8 wires, and the chipsets that support it. Auto-MDX is an feature of gigabit, I've never seen a gigabit port that didn't include it.



     
  7. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,169
    First Name:
    Terry
    Sometimes the specs for the computer or the ethernet will say "auto-sensing" or "MDI/MDIX." Or, as John said, all gigabit (1000/100/10 Mbps) adapters seem to be.

    When you connect two computers directly there is no Dhcp server so Windows assigns an APIPA (IP of form 169.254.x.y). If you connect a computer to a router (or to an ISP directly with a modem) you should get an IP assigned by a Dhcp server; if no Dhcp server is found the resulting APIPA indicates a problem. Windows seems to assume that you always want internet access so anytime it sees that an APIPA was assigned it warns about "limited connectivity." In short, when connecting two computers directly ignore "limited connectivity."

    Here's a way to see if the two computers can communicate. If all the pings fail it is probably because of a firewall blocking, but could also be a cable or NIC problem. If the pings fail one direction only it is almost definitely a firewall.

    To open a Command Window: Start - Run – cmd (command in 98SE) – OK
    (if Run not on Vista’s or 7’s Start menu, just type cmd in the Search box)

    To determine a computer's IP address: open a Command Window and type
    ipconfig

    Now for some troubleshooting:

    1. On each PC open a Command window and type
    ping IPofOther (where IPofOther is the IP address of the other PC)

    Do you get Replies, or do you get packets lost?

    If you got Replies,

    2. Do the same ping except use the Computer Name of the other computer:
    ping NameOfOtherPC

    Replies or lost packets?
     
  8. prunejuice

    prunejuice

    Joined:
    Apr 2, 2002
    Messages:
    3,432
    Good to know. Thanks.
     
  9. Agile

    Agile Thread Starter

    Joined:
    Jan 6, 2010
    Messages:
    24
    The NICs are -> PC: Realtek RTL8139 Family PCI fast Ethernet NIC
    Laptop: Broadcom NetXtreme Gigabit Ethernet

    Ipconfig for Laptop:

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : phub.net.cable.rogers.com
    IP Address. . . . . . . . . . . . : 192.168.0.193
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1

    Ethernet adapter Local Area Connection 3:

    Connection-specific DNS Suffix . :
    Autoconfiguration IP Address. . . : 169.254.188.188
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    ipconfig for Pc:

    Ethernet adapter Local Area Connection 7:

    Connection-specific DNS Suffix . :
    Autoconfiguration IP Address. . . : 169.254.197.55
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    I can ping by ip address but not by computer name.
     
  10. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,169
    First Name:
    Terry
    That's probably a firewall issue.

    You at least have basic communication, so you could try bridging the connections on the laptop to see if you have enough communication to get internet access on the desktop.
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Let's see this for each of the machines.


    Hold the Windows key and press R, then type CMD then press Enter to open a command prompt:

    In the command prompt window that opens, type type the following commands, one at a time, followed by the Enter key:

    Note that there is a space before the -n or the /ALL, but there is NOT a space after the - or / in the following commands.

    NBTSTAT -n

    IPCONFIG /ALL

    Right click in the command window and choose Select All, then hit Enter to copy the contents to the clipboard.
    Paste the results in a message here.

    If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
     
  12. Agile

    Agile Thread Starter

    Joined:
    Jan 6, 2010
    Messages:
    24
    Laptop
    NBTSTAT:

    Local Area Connection 3:
    Node IpAddress: [169.254.188.188] Scope Id: []

    NetBIOS Local Name Table

    Name Type Status
    ---------------------------------------------
    LAPTOP2 <00> UNIQUE Registered
    LAPTOP2 <20> UNIQUE Registered
    MSHOME2 <00> GROUP Registered
    MSHOME2 <1E> GROUP Registered
    MSHOME2 <1D> UNIQUE Registered
    ..__MSBROWSE__.<01> GROUP Registering

    Wireless Network Connection 2:
    Node IpAddress: [192.168.0.193] Scope Id: []

    NetBIOS Local Name Table

    Name Type Status
    ---------------------------------------------
    LAPTOP2 <00> UNIQUE Registered
    LAPTOP2 <20> UNIQUE Registered
    MSHOME2 <00> GROUP Registered
    MSHOME2 <1E> GROUP Registered
    MSHOME2 <1D> UNIQUE Registered
    ..__MSBROWSE__.<01> GROUP Registering

    ipconfig:

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : LAPTOP2
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Broadcast
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : phub.net.cable.rogers.com

    Ethernet adapter Local Area Connection 3:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
    Physical Address. . . . . . . . . : 00-16-D3-25-1E-96
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.188.188
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : phub.net.cable.rogers.com
    Description . . . . . . . . . . . : NETGEAR 108 Mbps Wireless PC Card WG
    511T
    Physical Address. . . . . . . . . : 00-0F-B5-62-2A-A4
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.0.193
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 192.168.0.1
    Lease Obtained. . . . . . . . . . : Tuesday, January 12, 2010 6:05:13 PM

    Lease Expires . . . . . . . . . . : Wednesday, January 13, 2010 6:05:13
    PM


    PC

    NBTSTAT:

    Local Area Connection 7:
    Node IpAddress: [169.254.197.55] Scope Id: []

    NetBIOS Local Name Table

    Name Type Status
    ---------------------------------------------
    COMPZORR <00> UNIQUE Registered
    COMPZORR <20> UNIQUE Registered
    MSHOME <00> GROUP Registered
    MSHOME <1E> GROUP Registered


    ipconfig:

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : COMPZORR
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 7:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC #2
    Physical Address. . . . . . . . . : 00-40-05-82-5E-9A
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.197.55
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
     
  13. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    Connect the two machines with a crossover Ethernet cable. If one or both of the machine have gigabit adapters or auto-MDX ports, an Ethernet patch cable will do the job.

    Configure the machines as follows.

    PC #1:
    IP address: 192.168.9.1
    Subnet Address: 255.255.255.0

    PC #2:
    IP address: 192.168.9.2
    Subnet Address: 255.255.255.0

    Leave the Default Gateway and DNS Server addresses blank.

    Make sure any firewalls are configured to put the 192.168.9.x subnet in the trusted zone.

    Finally, you'll have to enable file/print sharing on the machines and actually share one or more folders or drives.

    Here's a page that describes the process in detail: http://www.howtodothings.com/computers-internet/how-to-connect-2-pcs-directly
     
  14. Agile

    Agile Thread Starter

    Joined:
    Jan 6, 2010
    Messages:
    24
    Okay it's working now, I can see the other computer and it can see me, and I can access files and such. Thanks a lot for the help!

    One more question though, I want to share my wireless connection but when i go to set sharing on it tells me that it says that it will set my lan to 192.168.0.1. will this affect my wireless network? it is also using the 192.168.0.x range.
     
  15. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,169
    First Name:
    Terry
    First, you want to go back to dynamic addresses.

    Then bridge the wireless and ethernet connections.

    The other choice is to change the LAN subnet on the router (e.g., to 192.168.3.x) and enable ICS on the internet connection.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/893245

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice