1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Newly built computer will not turn on

Discussion in 'Hardware' started by matthewappel, Jan 9, 2015.

Thread Status:
Not open for further replies.
  1. matthewappel

    matthewappel Thread Starter

    Joined:
    Jan 9, 2015
    Messages:
    7
    My motherboard is a Gigabyte Gigabyte Black Edition LGA 1150 Intel Z97 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboards GA-Z97X-UD5H-BK
    I have an Intel Core i5 4690K LGA 1150 Processor
    I have a Corsair CS550M Power Supply
    I have a Corsair Carbide Series Black 500R Mid Tower Computer Case (CC-9011012-WW)

    Everything is connected correctly as far as I can see. Is there someone who can tell me what I may have done wrong that is stopping the computer from booting up?
     
  2. Amd_Man

    Amd_Man

    Joined:
    Oct 17, 2012
    Messages:
    605
    Did you mount the motherboard in the case using the standoffs?
     
  3. matthewappel

    matthewappel Thread Starter

    Joined:
    Jan 9, 2015
    Messages:
    7
    Ok I found the issue. The "sw pwr" was in the wrong spot. Thanks for the help.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1140854

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice