1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: No ping between WinXP and Win98 on wireless network

Discussion in 'Networking' started by syc0path, Jan 20, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. syc0path

    syc0path Thread Starter

    Joined:
    Nov 19, 2004
    Messages:
    273
    I have an old Win98 machine that I'm trying to network w/ my new WinXP machine. The XP machine has a wireless-g router and the 98 has a PCI wireless-g card. I'm getting cable internet sometime this week, but right now I don't have any internet access. BTW, the configuration utility for PCI card indicates that signal strength is at 100%.

    I did a search on this site and found some instructions, but I have some questions.

    1. Make sure you have the same IP scheme (eg 192.168.0.x)
    ***Should both computers have the same IP address (ie, x=100 for both, or x=100 for XP and 101 for 98)? I currently have them set to 100 and 101.

    2. Make sure you have the same Subnet Mask, Gateway, and DNS IP addresses.
    ***Subnet and gateway at the same, but do I need DNS? I left DNS blank in XP and DNS is disabled in 98. The instructions for both the router and the PCI card don't mention anything about DNS... if I do need it, what IP should I set it to?

    3. Make sure you can ping the other computer's IP address. If this fails, just for testing, make sure you turn off XP's as well as any other firewall.
    ***The Win98 machine isn't used for internet, so it doesn't have a firewall. The WinXP firewall is disabled. I went to the Start Menu, Run, and then typed "ping 192.168.0.100" or 101. I can't get either computer to ping the other. When I had them both set to 100, I got good ping (<1ms), but I assume that was becuz the computer was pinging itself.

    But even when I had good ping, I still couldn't see anything on the other computer, even though I had enabled several folders on each machine for sharing. Searching for other computers couldn't find anything.
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,926
    First Name:
    Terry
    I think you said you are connecting both PCs to a router, at least one wirelessly. Right? If so, why are you messin' with static IP configurations? If you want my advice ...

    Reset the router to factory default settings. Set both PCs to 'obtain IP auto' and 'obtain DNS auto.'

    Open a Command Window and type
    ipconfig /all

    That will show you the IP address of the computer. They will probably differ by one digit. On each you should also see the same address for Gateway and Dhcp server (that's your router's address).

    You should be able to ping the router and the other computer.

    Have you enabled file and printer sharing on either (or both) computer(s)? I don't mean set a specific folder to be shared--I mean enabling file and printer sharing so that it is possible to share folders.

    Once you get the network (pings successful) working you can then enable encryption on the router and again connect wirelessly and try pings again to be sure.
     
  3. syc0path

    syc0path Thread Starter

    Joined:
    Nov 19, 2004
    Messages:
    273
    I just followed the instructions that came w/ the router and the PCI card... those were the IP addresses the instructions said to use. But I'll try your suggestions, becuz following the instructions obviously isn't working. I've enabled file and printer sharing, but that's not gonna do much good if I can't even get them to ping. :(
     
  4. etaf

    etaf Moderator

    Joined:
    Oct 2, 2003
    Messages:
    65,251
    First Name:
    Wayne
    also check any firewalls are not blocking the connection - you should be able to set up a range of IP address which can access the PC's

    I would also suggested posting IPCONFIG /ALL for both PC's here

    ipconfig /all

    TWO Methods to do that - some people have problems with ONE----

    ONE ---------------------------------
    start
    run
    cmd (command on win98 PC)
    ipconfig /all

    rightclick in the box
    select all
    enter
    control key + C key - to copy
    then reply here and
    control key + V to paste

    TWO -----------------------------------------------

    Start, Run, CMD (command on win98 PC) to open a DOS window and type:

    IPCONFIG /ALL >C:\RESULT.TXT

    Open C:\RESULT.TXT with Notepad and copy/paste the entire results here.
     
  5. syc0path

    syc0path Thread Starter

    Joined:
    Nov 19, 2004
    Messages:
    273
    There isn't any auto DNS setting in Win98. But it didn't seem to work anyway... the auto settings were way different from each other. So I auto-configured XP and set 98 to match. When DNS is enabled in 98, what Host and Domain names should I use? I tried the XP computer's name as Host and the network name as Domain, but it didn't work.

    Here are the WinXP auto settings:

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : medlib
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : SiS 900-Based PCI Fast Ethernet Adapter
    Physical Address. . . . . . . . . : 00-0C-6E-D8-14-FB
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.101
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.254
    DHCP Server . . . . . . . . . . . : 192.168.1.254
    DNS Servers . . . . . . . . . . . : 192.168.1.254
    Lease Obtained. . . . . . . . . . : Monday, January 22, 2007 7:02:00 PM
    Lease Expires . . . . . . . . . . : Thursday, February 01, 2007 7:02:00 PM


    Here are the Win98 settings that I manually configured to match the WinXP auto settings:

    Windows 98 IP Configuration

    Host Name . . . . . . . . . : medlib.house
    DNS Servers . . . . . . . . : 192.168.1.254
    Node Type . . . . . . . . . : Broadcast
    NetBIOS Scope ID. . . . . . :
    IP Routing Enabled. . . . . : No
    WINS Proxy Enabled. . . . . : No
    NetBIOS Resolution Uses DNS : Yes

    0 Ethernet adapter :

    Description . . . . . . . . : PPP Adapter.
    Physical Address. . . . . . : 44-45-53-54-00-00
    DHCP Enabled. . . . . . . . : Yes
    IP Address. . . . . . . . . : 0.0.0.0
    Subnet Mask . . . . . . . . : 0.0.0.0
    Default Gateway . . . . . . :
    DHCP Server . . . . . . . . : 255.255.255.255
    Primary WINS Server . . . . :
    Secondary WINS Server . . . :
    Lease Obtained. . . . . . . :
    Lease Expires . . . . . . . :

    1 Ethernet adapter :
    Description . . . . . . . . : IEEE 802.11g Wireless Cardbus/PCI Adapter
    Physical Address. . . . . . : 00-18-E7-0A-F7-FF
    DHCP Enabled. . . . . . . . : No
    IP Address. . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . : 192.168.1.254
    Primary WINS Server . . . . :
    Secondary WINS Server . . . :
    Lease Obtained. . . . . . . :
    Lease Expires . . . . . . . :

    I entered the correct values for DHCP in Win98, but they don't show up for some reason:( For comparison's sake, here at the auto config settings from Win98:


    Windows 98 IP Configuration

    Host Name . . . . . . . . . : medlib.house
    DNS Servers . . . . . . . . : 192.168.1.254
    Node Type . . . . . . . . . : Broadcast
    NetBIOS Scope ID. . . . . . :
    IP Routing Enabled. . . . . : No
    WINS Proxy Enabled. . . . . : No
    NetBIOS Resolution Uses DNS : Yes

    0 Ethernet adapter :
    Description . . . . . . . . : PPP Adapter.
    Physical Address. . . . . . : 44-45-53-54-00-00
    DHCP Enabled. . . . . . . . : Yes
    IP Address. . . . . . . . . : 0.0.0.0
    Subnet Mask . . . . . . . . : 0.0.0.0
    Default Gateway . . . . . . :
    DHCP Server . . . . . . . . : 255.255.255.255
    Primary WINS Server . . . . :
    Secondary WINS Server . . . :
    Lease Obtained. . . . . . . :
    Lease Expires . . . . . . . :

    1 Ethernet adapter :
    Description . . . . . . . . : IEEE 802.11g Wireless Cardbus/PCI Adapter
    Physical Address. . . . . . : 00-18-E7-0A-F7-FF
    DHCP Enabled. . . . . . . . : Yes
    IP Address. . . . . . . . . : 169.254.221.23
    Subnet Mask . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . :
    DHCP Server . . . . . . . . : 255.255.255.255
    Primary WINS Server . . . . :
    Secondary WINS Server . . . :
    Lease Obtained. . . . . . . : 01 22 07 8:54:28 PM
    Lease Expires . . . . . . . :
     
  6. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Doesn't look like the last Win98 listed computer is getting a valid IP address:
    IP Address. . . . . . . . . : 169.254.221.23
     
  7. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,926
    First Name:
    Terry
    Make sure encryption is disabled until you get the wireless to communicate. With the wireless utility on the Windows 98 do you detect the wireless signal? What happens when you try to connect to it?

    Bob, does Windows 98 support wireless, or is 98SE required?
     
  8. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,926
    First Name:
    Terry
    I skimmed over something in last post. I know the wireless is not communicating because the 98 didn't get a good IP config. If you go back to using static (I don't recommend) then try to ping the router:
    ping 192.168.1.254
    to determine if there is communication. Until this ping works, no sense in trying to talk with the other computer.
     
  9. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Exactly. That's why I mentioned that it doesn't look like the last Win98 listed computer is getting a valid IP address: IP Address. . . . . . . . . : 169.254.221.23

    I have seen Win98SE computers that are supposed to be able to connect wireless still have problems.
     
  10. syc0path

    syc0path Thread Starter

    Joined:
    Nov 19, 2004
    Messages:
    273
    Well that ended up being the problem... I opened the PCI card utility on the Win98 machine and the settings had been changed. I think it's supposed to be set to "access point" but it was actually set to "MyLAN infrastructure" or something like that. It's weird though, becuz I know I had 100% signal strength before... so it was either reset to default settings, or I might have accidentally changed it while I was trying to find the right settings.

    In any event, IT WORKS!!:D

    It's hard to say exactly when it was changed off "access point", so I don't know when the underlying IP config problem was solved. But it seems like the process of running auto config in WinXP and then manually setting Win98 to match is what did it. I have full access to files and folders from both machines to the other, and I also successfully enabled WEP encryption:)

    1 minor annoyance though... now whenever I start the Win98 machine, it asks for a password for Microsoft Networking before it fully boots up. Is there any way to bypass this? I'm not using a password on either machine, but it still asks. I used to have a similar issue on my old work computer, so I'm guessing there's no way around it(n)

    Bob, I found your link to solve the browsing delay issue, so I'll be applying that fix tonight.

    Thanx for all your help guys(y) :D
     
  11. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,926
    First Name:
    Terry
    "... it asks for a password for Microsoft Networking before it fully boots up. Is there any way to bypass this?"

    Windows XP. :( I remember trying to find a solution for my daughter for several years. Nothing I found worked for her, and I didn't keep the attempts I found.

    You're welcome for our help, and you can mark this 'solved' using the Thread Tools in the upper right.
     
  12. Bob Cerelli

    Bob Cerelli

    Joined:
    Nov 2, 2002
    Messages:
    22,468
    Yes, there is a way to bypass the prompt for a logon with Win98. Download TweakUI for Win98 from Microsoft and configure it to autologon with whatever account and password you are using manually
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/536951

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice