1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: No sound from modem

Discussion in 'Windows XP' started by MichaelH1, Nov 8, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. MichaelH1

    MichaelH1 Thread Starter

    Joined:
    Nov 8, 2006
    Messages:
    5
    Does anyone have some suggestions on how I can get sound from my modem?

    I have a new Toshiba Portege R200 laptop with Win XP Version 2002 SP2 with a built-in Toshiba Software modem on COM3. When I dial out with the modem there is no sound, although the modem does work and connects to my server.

    · The sound works for other apps and Windows itself, so I know the speakers work.
    · I moved my disk drive into another laptop and had the same problem, so it’s a software issue and not a hardware problem.
    · In Control Panel Sounds and Audio Device settings, the master volume is set to High and the Volume Control, Phone, Mono Out and other volume settings are all High.
    · In the Control Panel Phone and Modem Options, the modem speaker volume is set to High
    · In the Modem Properties, it says the device is working properly
    · Through HyperTerminal, I sent the AT&F, ATM2, and ATL3 commands to be sure everything was set properly (and the response to all was OK)
    · I uninstalled and reinstalled the modem driver
    · It’s a new laptop with standard software and hardware so there are no conflicts

    Has anyone see this problem with the modem not making any sounds? Suggestions?

    Thanks!

    Mike
     
  2. Sponsor

  3. Joanyoung

    Joanyoung

    Joined:
    Jun 18, 2004
    Messages:
    1,122
    Yes, there is an option to turn on or off sound on the modem, why have sound turned on anyway?

    I had a modem that when I had sound turned on I got a slower connection, so kept sound turned off

    joan
     
  4. MichaelH1

    MichaelH1 Thread Starter

    Joined:
    Nov 8, 2006
    Messages:
    5
    Joan, thank you for your very fast reply!

    I need the sound because I sometimes dial with a calling card, and I need to hear the messages to control the timing.

    In the Control Panel Phone and Modem Options, the modem speaker volume is set to High. Is that the off/on option you are referring to, or is there another setting somewhere else?

    Thanks for your help!
     
  5. ahunt2

    ahunt2

    Joined:
    Jan 12, 2008
    Messages:
    4
    In the last week or so I have encountered the same problem. My Agere softmodem works okay but there is no audio now. This is on XP Pro on a HP xw4400 workstation. I have tried changing the audio level on the modem and the system but neither has an impact. The speaker works for all other tasks.

    This was working but sudenly stopped. I like to have the audio to detect problems with the phone line quickly.
     
  6. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    The modem speaker is controlled on each individual dial-up connection.
    Open the Network Connections folder (Start | Control Panel | Network Connections)
    Right click the connection
    On general tab click the Configure... button
    Check the Enable Modem Speaker box

    That should get it sputtering/growling/whistling at ya

    HTH

    Jerry
     
  7. ahunt2

    ahunt2

    Joined:
    Jan 12, 2008
    Messages:
    4
    I checked this and it was enabled. I tried toggling it but no effect. This worked fine until about the last week. The only change was six security updates to Windows XP Pro that I installed but none seem to mention anything related to this problem. Aother friend also looked through the system today but say nothing wrong.
     
  8. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    Guess it's not going to be an easy one.
    One quick check, start Hyperterminal and try dialing and see if you hear sound
    Start Hyperterminal, enter a name like test click OK
    enter anything for a phone number and click OK
    Click cancel on the next window
    type the following and press enter after each line:
    ATE1 <--So you can see what you are typing
    AT&FM2L3
    ATDT5555550199
    <-- use your phone number or your ISPs
    The modem should dial and give you a busy signal (if you used your number) or connect to your ISP and you should hear it. If you don't hear it, it's either the hardware, or a driver issue.
    Close the window and do not save the connectoid
    If that works, goto Control Panel, Phone and Modem options, Modems tab, Properties, Advanced tab, enter AT&FM2L3 in the extra initialization commands box. (Sending them in hyper terminal only works for that session)
    You may want to try just ATM2L3 -- you might get better connections by just adding the speaker commands to the default init string instead of replacing the init string.
    You can also use M1 instead of M2, that will turn the speaker off after the connection is established, but should still let you hear what you need for using a calling card.

    If that doesn't do it, here's afew more things to check:
    Control Panel Sounds and Audio Device
    • Audio tab - make sure Use only default devices is not checked
    • Hardware Tab - Highlight each audio device, click properties, goto properties tab, expand any devices present and check properties on each.
      • Use audio features on this device should be selected (if present)
      • Do not map through this device should not be checked.

    If your sound card has a mixer application, check to make sure it doesn't have something muted that is not showing up in the Windows Volume control.

    That's about all I can think off, hopefully something there will work for ya.

    Jerry
     
  9. ahunt2

    ahunt2

    Joined:
    Jan 12, 2008
    Messages:
    4
    The Hyperterminal test was silent as well and I found no setting problems else where. I found the Agere device driver DVD and reinstalled the driver. The sound came back. I then installed the Agere driver update from Microsoft Update that had been installed and working okay. The sound continued to work after it was installed as well.

    I had installed the following six Microsoft updates after which the modem quit making a sound but otherwise worked okay.

    KB942763
    KB941568
    KB942840
    KB944653
    KB937894
    KB941569

    I suspect one of these may have hit something. Appreciate the help and direction. Another problem solved although not fully understood cause wise.
     
  10. MichaelH1

    MichaelH1 Thread Starter

    Joined:
    Nov 8, 2006
    Messages:
    5
    Thanks, Jerry, for your help. Unfortunately my modem still doesn't generate any sound.

    - I tried the modem commands you suggested in Hyperterminal, still doesn't work
    - I unchecked "Use only default devices", still doesn't work
    - "Use audio features on this device" was selected for SoundMAX Integrated Digital Audio, "Do not map through this device" was not checked

    Music, beeps, and other sounds work fine. The system is a Toshiba Portege laptop with Win XP SP 2. Any other ideas?

    Thanks,

    Mike
     
  11. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    If you can't hear sounds in Hyperterminal, I would think it's either a corrupted Driver, or a hardware problem. ahunt2 re-installed the drivers and got sounds back. You may want to download the drivers from Toshiba and re-install them using the update driver button from within Device Manager.
    Looks like there are several sub models for the R200 (R200-S2XXX) so I'm not sure which driver to link to (there are two), so here is the link to the model selection page:

    http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_modSel.jsp

    You may also need to re-install the Audio drivers for the sound card. The "Link" to the modem may have gotten corrupted.

    Check the Device Configuration and see if there is a setting to disable modem sounds:

    1. Click Start, All Programs, Toshiba.
    2. Point to Utilities, then select Toshiba Assist. The TOSHIBA Assist window appears.
    3. Click the Optimize tab.
    4. Double-click the Toshiba Hardware Settings icon. The TOSHIBA HWSetup window appears.
    5. Click the Device Configuration Tab

    You said you put your hard drive into another laptop. Was it an identical model including the submodel#, and the modem speaker works in that one?
    Did you by chance put that hard drive into your laptop to see if the modem sounds worked with their hard drive?
    Did the modem speaker work previously, then stop, or has it never worked?

    HTH

    Jerry
     
  12. MichaelH1

    MichaelH1 Thread Starter

    Joined:
    Nov 8, 2006
    Messages:
    5
    Jerry - thank you very much for your help. The modem sound is now working. I downloaded and installed the latest modem driver from the Toshiba website and that fixed the problem. The problem may have been from a corrupted modem driver (although the modem worked fine other than no sound), or perhaps the O/S base image installed on my laptop may have been built for a slightly different laptop model and this problem was overlooked.

    Mike
     
  13. TheOutcaste

    TheOutcaste

    Joined:
    Aug 7, 2007
    Messages:
    9,028
    You're Welcome!

    If your issue has been resolved you (and ONLY you) can use the Thread Tools at the Upper Right to mark this thread Solved.:)

    Jerry
     
  14. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/516599