1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Not valid ip configuration plus UBS tether fail PLUS itunes phone fail

Discussion in 'Networking' started by rooock, Apr 4, 2015.

Thread Status:
Not open for further replies.
Advertisement
  1. rooock

    rooock Thread Starter

    Joined:
    Apr 4, 2015
    Messages:
    4
    Hi guys a lot of research online brings me here, and I hope this will be the last stop before I put my fist through the screen of my laptop. :D

    So a few days ago my computer can't connect to wireless, stuck in Limited mode. Troubleshoot says - "wireless connection doesn't have a valid ip configuration". i've uninstalled the driver, put valid settings from another laptop I have, I've uninstalled Bonjour, i've put netsh commands.. still nada. The USB connection I could use to tether also stopped working. I've tried other wifi connections and they don't work either. The strangest thing is that itunes won't recognize the phone, but windows does and i can go inside the folders.


    I have the 169.254.x.x ipconfig forgot the name but like I've read here before it can't get to DHCP.

    The laptop is 6 months old lenovo windows 7.


    Would really appreciate some input on what else to try. Thank you!
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    79,610
    First Name:
    Terry
    Can you successfully connect by ethernet?

    What firewall or security suite is, or ever was, on the system?
     
  3. rooock

    rooock Thread Starter

    Joined:
    Apr 4, 2015
    Messages:
    4
    I don't have a chance to try this at this time.


    for security, I kept having my browser hijacked with pop up tab, so i installed hitmanpro, adwcleaner and Malwarebytes. I suspect one of these could be the culprit but can't revert to an earlier stage.

    i also have comodo but it is turned off. default firewall I set to off while I'm investigating.
     
  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    79,610
    First Name:
    Terry
  5. rooock

    rooock Thread Starter

    Joined:
    Apr 4, 2015
    Messages:
    4
    Thank you so much Terry, that did the job!

    I am surprised because things worked fine with comodo for 2-3 months!

    Thank you once again, any recommendations for an easy free protection program?

    Also my browser is still hacked by pop up advertising tabs, extensions look fine though.
     
  6. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    79,610
    First Name:
    Terry
    You're welcome. :)

    Often Comodo, Norton, etc., work fine for months or years before becoming corrupted. You can reinstall it if desired.

    See the Security forum for a bunch of recommendations. I prefer to use the Windows firewall and for Windows 7 Microsoft Security Essentials. Once in awhile, if I suspect some problem, I'll run MalwareBytes and SuperAntiSpyware.
     
  7. rooock

    rooock Thread Starter

    Joined:
    Apr 4, 2015
    Messages:
    4
    Will check SAS out, thanks again, marked solved.
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1145969

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice