1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: pci.sys Software Hardware I dunno what ware

Discussion in 'Windows XP' started by blrender, Oct 18, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. blrender

    blrender Thread Starter

    Joined:
    Jun 25, 2004
    Messages:
    44
    heyas;

    so yesterday i power up my computer and... it comes up with the, 'hey, your pci.sys file is screwt. go fix it.' message. so i look this up on google, on here, everywhere, and i come up with a couple of solutions that are suppose to work. i have tried these solutions. they didn't work :(

    solution 1: pci.sys software

    i did the XP recovery thing. i expanded pci.sy_ from the i385 directory on the cd. i also tried copying pci.sys from my second hard drive, which had the old xp install on it. then i tried using an SP2 interleaved (or whatever you call it) installation cd i had made, and used THAT pci.sy_ file.

    still started with the pci.sys error.


    solution 2: pci.sys hardware

    i took out memory stick #1. rebooted. no joy. i took out memory stick #2. ditto. i took out memory stick #3, i didn't even get the screen to come up. i put the memory back in.

    i took out a wireless nic card i have in the pci slot. rebooted. no joy. i put it back in.
    i took out my pci-e video card (not even sure that's the same bus, but what the heck). rebooted. no joy.




    and that's all that's in there! no sound card or anything. IS there a procedural anomaly because i did it backwards? that is, instead of ripping EVERYTHING out first, and putting back in one by one, i just ripped out one at a time?

    also note: my power supply in this machine blew out 3 weeks ago. i got a replacement and powered it up and everything ran fine, so presumably it did not blow up anything when it went. but now, i have this :(

    what else can i do??



    system specs: (from my paper on this system; i dont necessarily know what it all means :X )

    mobo: ASUS A8N-VM Nvidia Geforce 6100 chipset; DDR400 PCIex16
    pro: AMD Athlon 64 3500+ 2.2 G
    mem: 2x DDR 400 2.1G PC3200 SDRAM DIMM nonECC and 1x a memory stick that came from a previous order
    vid: ATI Radeon X850XT 256MDDR
    aud: none (onboard sound, but that doesn't seem to be working; though it used to have a sound card 5 years ago or so)
    HDs: 1: Maxtor 120G EIDE
    2: Seagate 160 Barracuda SATA 3G/s
    nic: EDIMAX EW-7128G IEEE 802.11b/g
    psu: ANTEC, Basiq BP500U, 500W, 24-pin ATX12V EPS12V, One 6-pin PCIe (new)
     
  2. blrender

    blrender Thread Starter

    Joined:
    Jun 25, 2004
    Messages:
    44
    today i ran MemTest86 v4 on it.

    one standard pass. no errors. it can't be the motherboard, can it???



    i am tempted to try this procedure:
    http://tech.icrontic.com/articles/repair_windows_xp/

    eight steps to fix xp. but though it has stops with similar errors, it does not mention the pci.sys file. does anyone think this could help??
     
  3. blrender

    blrender Thread Starter

    Joined:
    Jun 25, 2004
    Messages:
    44
    okay...

    i did the test the right way. i ripped out all the pci and pcie cards, and the 3 memory sticks. i got the same results. with no memory in at all, the system posts, but nothing comes up on the screen at all. not even the bios stuff.

    i put in one stick, i get the pci.sys error. any stick. in any slot. there is no configuration of pieces that makes the error NOT happen.


    is there a particuarl pci.sys file for xp sp3? instead of sp2? one thread one guy was screaming use the pci from sp2, not the default. well, i tried that. i don't have an sp3 integrated xp install disk.
    is there even a remote chance that the file did get corrupted and it won't play nice until i give it a shiny new xp3 pci.sys file?


    i'm at the end of my rope here, guys!
     
  4. blrender

    blrender Thread Starter

    Joined:
    Jun 25, 2004
    Messages:
    44
    okay, i'm an idiot.

    after careful analysis of the boot.ini, (or the bootcfg /list command), i have discovered that my machine is actually booting windows from the SECOND hdd, not the first. :X

    so.

    i have replaced the pci.sys file on the D: drive from the XP SP2 slipstreamed cd. (i finally remembered the right word for that), and the sucker is working.

    gawd.

    ::DIES::
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Software Hardware
  1. nitro1x1x2
    Replies:
    5
    Views:
    491
  2. snowbal
    Replies:
    5
    Views:
    582
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1022825