1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: PhpMyAdmin:#2002 - The server is not responding (or the local MySQL server's

Discussion in 'Web Design & Development' started by Bagslash, May 2, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. Bagslash

    Bagslash Thread Starter

    Joined:
    May 2, 2011
    Messages:
    2
    Good afternoon,

    I was hoping somebody could help me out, I installed Wamp on my pc a while ago and was using it with Joomla and all was going well. I had to start afresh with it all (for various clean up reasons) and uninstalled Wamp. I then reinstalled it and got the error message:

    #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

    when trying to connect to PhpMyAdmin. I tried several times with no luck. I have since tried Xampp to see if MySql would respond differently, but it flags the same error.
    I have Googled the issue extensively and there are some resolutions which involve changing various files, but I'll be completely honest and say I haven't got a clue where to find these files (sorry). I have checked the task manager and mysqld.exe is running so that's definitely not an issue, it also listed as ACTIVATED in the Xampp manager.
    Please respond to me as if I'm a child as I am so bogged down with it all now!

    Thank you so much in advance!

    Carla
     
  2. ehymel

    ehymel

    Joined:
    Aug 12, 2007
    Messages:
    695
    Definitely sounds like a mysqld problem. Some ideas:

    - Are you trying to use a password when there isn't one, or are you using the correct username and password if one is configured?

    - Do you have a firewall installed, and if so is it set up to allow connections to mysql?

    - Have you tried stopping and re-starting the mysqld service?

    - Have you checked your log files for errors?
     
  3. Bagslash

    Bagslash Thread Starter

    Joined:
    May 2, 2011
    Messages:
    2
    Thank you so much for replying! After 11 hours of head scratching I think I have just this second cracked it! I went into the my.ini file and changed the setting for mysql socket = "MySQL" to "/tmp/mysql.sock" and then did the same in the php ini file and it suddenly appeared!! I'm chuffed to bits!

    Thank you again for taking the time to read my post.

    Carla
     
  4. Corvin666

    Corvin666

    Joined:
    Jun 8, 2011
    Messages:
    1
    Thanks a lot for the idea.

    The same trick fixed MySQL for Windows7 - I set mysql.default_socket = "c:/tmp/mysql.sock"
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/994597