1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Please help! All shortcut icons replace??

Discussion in 'Windows XP' started by otaku7730, Aug 27, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. otaku7730

    otaku7730 Thread Starter

    Joined:
    Apr 14, 2007
    Messages:
    21
    Ok, I've got a bit of an issue that has never occured before. To give you the (sort of) quick version: usually, I'm fairly careful about where I go and what I do online to avoid malware. However, I picked *something* up a few days back that spewed it all over my hard drive. Ran SAS, cleared a ton of stuff, and restarted, only to find my PC in a boot loop. Tried repairing windows incase SAS deleted an important .dll or something, but ended up having to completely reformat. Installed AVG immediately upon reformat, and everything's been fine the past few days.
    However, last night something happened, and I don't know what triggered it. All of my icons (desktop, folders, start menu), were replaced by the generic windows icon. I'm able to click on most of the shortcuts and reassign the original icon, but for certain items like the recycling bin, I'm unable to do so (and attempting to restore the default under desktop options does nothing, either). While it's not that big an issue at the moment, I'm afraid there's something more going on here... although an additional AVG scan showed nothing but some tracking cookies.

    Here's the hijack this log:

    Logfile of Trend Micro HijackThis v2.0.2
    Scan saved at 12:27:08 PM, on 8/27/2008
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)
    Boot mode: Normal

    Running processes:
    C:\WINDOWS\System32\smss.exe
    C:\WINDOWS\system32\winlogon.exe
    C:\WINDOWS\system32\services.exe
    C:\WINDOWS\system32\lsass.exe
    C:\WINDOWS\system32\svchost.exe
    C:\WINDOWS\System32\svchost.exe
    C:\WINDOWS\system32\spoolsv.exe
    C:\WINDOWS\Explorer.EXE
    C:\PROGRA~1\AVG\AVG8\avgtray.exe
    C:\Program Files\Creative\Sound Blaster X-Fi\Volume Panel\VolPanlu.exe
    C:\WINDOWS\system32\Rundll32.exe
    C:\WINDOWS\system32\RUNDLL32.EXE
    C:\Program Files\DAEMON Tools Lite\daemon.exe
    C:\PROGRA~1\AVG\AVG8\avgwdsvc.exe
    C:\WINDOWS\system32\CTsvcCDA.exe
    C:\WINDOWS\system32\nvsvc32.exe
    C:\PROGRA~1\AVG\AVG8\avgrsx.exe
    C:\PROGRA~1\AVG\AVG8\avgemc.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\PROGRA~1\AVG\AVG8\aAvgApi.exe
    C:\WINDOWS\system32\wuauclt.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

    O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll
    O2 - BHO: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL
    O3 - Toolbar: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL
    O4 - HKLM\..\Run: [AVG8_TRAY] C:\PROGRA~1\AVG\AVG8\avgtray.exe
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
    O4 - HKLM\..\Run: [VolPanel] "C:\Program Files\Creative\Sound Blaster X-Fi\Volume Panel\VolPanlu.exe" /r
    O4 - HKLM\..\Run: [P17Helper] Rundll32 SPIRun.dll,RunDLLEntry
    O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit
    O4 - HKLM\..\Run: [CTRegRun] C:\WINDOWS\CTRegRun.EXE
    O4 - HKCU\..\Run: [DAEMON Tools Lite] "C:\Program Files\DAEMON Tools Lite\daemon.exe" -autorun
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program Files\AVG\AVG8\avgpp.dll
    O20 - AppInit_DLLs: avgrsstx.dll
    O23 - Service: AVG Free8 E-mail Scanner (avg8emc) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgemc.exe
    O23 - Service: AVG Free8 WatchDog (avg8wd) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgwdsvc.exe
    O23 - Service: Creative Service for CDROM Access - Creative Technology Ltd - C:\WINDOWS\system32\CTsvcCDA.exe
    O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe

    --
    End of file - 2952 bytes



    If anyone can help me figure out what's going on here and what I can do, it would be greatly appreciated!
     
  2. Tufenuf

    Tufenuf

    Joined:
    Jul 28, 2007
    Messages:
    2,461
    otaku7730, Right click your Desktop, choose Properties, under the Settings tab change the Color Quality from 32 bit to 16 bit, click Apply/OK. Now go back and change it from 16 bit to 32 bit, click Apply/OK. This should rebuild the iconcache.db file and may correct your problem.

    Tufenuf
     
  3. -Fabez-

    -Fabez-

    Joined:
    Jul 28, 2008
    Messages:
    1,899
    Did you format the drive then reinstall or just install over the old windows ?
     
  4. Tufenuf

    Tufenuf

    Joined:
    Jul 28, 2007
    Messages:
    2,461
    otaku7730, If the instructions I posted in my previous reply do not correct the icon problem go to the link below and download the "ShellIconFix" utility, unzip it and run it. I don't believe you have a virus/malware problem.

    http://windowsxp.mvps.org/shelliconfix.htm

    Tufenuf
     
  5. otaku7730

    otaku7730 Thread Starter

    Joined:
    Apr 14, 2007
    Messages:
    21
    @ Fabez
    Come on, give me some credit! Just kidding; yeah, I ran the reformat before installing XP again.

    @ Tufenuf
    Thanks, that fixed it immediately!
     
  6. Tufenuf

    Tufenuf

    Joined:
    Jul 28, 2007
    Messages:
    2,461
    otaku7730, Glad to see that the icon problem is fixed and Thanks for posting back to let us know.

    Tufenuf
     
  7. -Fabez-

    -Fabez-

    Joined:
    Jul 28, 2008
    Messages:
    1,899
    Well I was just making sure :D Glad it worked for you :D
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Please help
  1. ZawMyoLatt
    Replies:
    4
    Views:
    223
  2. Clueless63
    Replies:
    1
    Views:
    248
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/744267

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice