1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: print spool service missing

Discussion in 'All Other Software' started by DAGO1C, Nov 28, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. DAGO1C

    DAGO1C Thread Starter

    Joined:
    Dec 5, 2006
    Messages:
    21
    print spooler not running??
    hadn't used my printer in sometime and found that it was gone from my computer. tried to install by adding new printer and got the "print spooler service is not running".

    well at first thought it was the printer and bought a new printer, well we all know what happened....nothing, same thing again.

    went on this forum and found threads with same problem and tried the solutions posted with no luck.
    went into services to print spooler and it was already set on automatic and when tried to hit start it says "could not start the print spool service on local computer. Error 2: the system can not find the file specified"

    also checked to see if the RPC file was open or running and it was. also UPnP is running at this time.
    any further ideas would be great.
    thanks
     
  2. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
    Click Start > Run > type (or paste):

    Code:
     
    cmd /k reg query "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler" /s
    
    Copy (right-click and Select All > press Enter) the entire content of that window and paste it into your next reply.


    Also, go to C:\WINDOWS\system32\spoolsv.exe

    Do you have that file?
     
  3. DAGO1C

    DAGO1C Thread Starter

    Joined:
    Dec 5, 2006
    Messages:
    21
    I can only screen print and then send as as attachment. I don't know how to attach Confused as how to attach screen print
    No spoolsvc.exe is not in system 32
     
  4. stantley

    stantley

    Joined:
    May 22, 2005
    Messages:
    7,091
    Maybe this was a typo "No spoolsvc.exe is not in system 32", but just to be clear the exact filename is spoolsv.exe and not spoolsvc.exe.

    Do a Windows search for spoolsv and see if you have another version of the file somewhere.

    Before you do the search click on "More advanced options" and make sure "Search system folders", "Search hidden files and folders" and "Search subfolders" are all checked.
     
  5. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
  6. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
    Why??? Can't you run the following command and copy/paste the results?

     
  7. DAGO1C

    DAGO1C Thread Starter

    Joined:
    Dec 5, 2006
    Messages:
    21
    i solved problem without making a restore. just copy spoolsv.exe and the spoolsv.dll from C:\Windows\ServicePackFiles\I386 and paste in sistem32. Then downloaded drivers from epson...All up and printing again...Thanks for your help this is solved...
     
  8. Phantom010

    Phantom010 Trusted Advisor

    Joined:
    Mar 9, 2009
    Messages:
    34,761
    You're welcome!
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/965334

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice