Solved: radeon vista issues

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

digi_astrid

Thread Starter
Joined
Mar 11, 2007
Messages
12
ok so I have a driver issue with my radeon saphire X1650 pci express card and vista worked fine on xp but then decided to upgrade to vista looked so nice on my husbands pc and works fine. I built this one myself. I know its a vista/driver issue cause I uninstall it pc runs pretty fast put it on is slow down extremly and hangs. won't run games. I have a amd 64 fx dual core processor 4 gigs of ddr2 ramm and the card has 512mb 2 hard drives that are 250 gigs each. I got a 32 bit vista but I think I may need 64. I've looked and looked and I find forums with people having this issue but no solution.
 

digi_astrid

Thread Starter
Joined
Mar 11, 2007
Messages
12
like I said it runs extremley slow and hangs and I can't run any games I don't have another couple of hundred lying around to get a new card and the drivers are supposed to be vista. but can't really do anything on the pc without uninstalling the driver so I know its got to be a driver issue.
 
Joined
Aug 1, 2003
Messages
51,988
Completely uninstall the driver. Remove the drivers from Device Manager and uninstall anything you see in Programs & Features. Delete the folders. Then, run one of these cleaners to get any remaining pieces.

Driver Cleaner Professional
Nasty File Remover

Reboot and install another driver. The latest may not be the best. Check the archived drivers and install one that came out a while after your card did (or your machine).
 

digi_astrid

Thread Starter
Joined
Mar 11, 2007
Messages
12
yup no help I can't find anything and haven't gotten a responce from ati and well you know windows it will cost me to ask them for help.
 

digi_astrid

Thread Starter
Joined
Mar 11, 2007
Messages
12
had to go thru the ati sapphire faq to get a link to vista beta drivers and that worked.:)
 
Joined
Aug 1, 2003
Messages
51,988
Good news. Glad you found those. If they work OK, you better stick with them.

You can mark your own threads "solved" using the Thread Tools above.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top