1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Really Slow Wi-Fi Speed

Discussion in 'Networking' started by pong40206, Jul 18, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. pong40206

    pong40206 Thread Starter

    Joined:
    Jul 18, 2013
    Messages:
    4
    I just bought a new Laptop with Windows 8. But when I tried to connect to Wi-Fi the first time switch it on, it did connect but it can't access to the internet (It said "Limited"). So I re-installed the wi-fi driver. The "Limited" warning was gone but the internet speed was really slow (The laptop wasn't too far from the router).
    I had also tried to change the wi-fi channel but it still slow. I just used windows 8 for the first time, did I miss some configuration? Other devices in my house can connect to this Wi-fi network and work fine, except this new laptop.

    Thank you for any further answers and helps.

    PS. Please excuse my poor English :)
     

    Attached Files:

  2. pong40206

    pong40206 Thread Starter

    Joined:
    Jul 18, 2013
    Messages:
    4
    And this is a wi-fi inspector screen shot from another laptop located in nearly the same location.
     

    Attached Files:

  3. pong40206

    pong40206 Thread Starter

    Joined:
    Jul 18, 2013
    Messages:
    4
    Also "ipconfig /all" of the slow one.
     

    Attached Files:

  4. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,171
    First Name:
    Terry
    Probably wrong driver or loose antenna.

    Make sure you have the latest wireless driver from the laptop manufacturer's web site.

    If the wireless card is easily accessible through a cover on the laptop's bottom make sure the antenna leads are secure.
     
  5. pong40206

    pong40206 Thread Starter

    Joined:
    Jul 18, 2013
    Messages:
    4
    It was a loose antenna as you said.
    It works fine now ,Thank you very much!!
     
  6. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    77,171
    First Name:
    Terry
    You're welcome. :) You did the good troubleshooting; those two Xirrus screen shots were pretty definitive!

    You can mark this solved using the [​IMG] button at the upper left of the page or just below the last post.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Really Slow
  1. Sassyapple
    Replies:
    8
    Views:
    264
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1103953

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice