1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Remote Procedure Call Term. Unexpectedly

Discussion in 'Windows XP' started by Kanester, Jan 27, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. Kanester

    Kanester Thread Starter

    Joined:
    Jan 27, 2006
    Messages:
    3
    I was installing new antivirus software and the computer was rebooted before the install completed. Now when I turn the computer on I get a SVCHOST.exe application error. It asks me to click OK to terminate or CANCEL to debug. No matter what I choose it pops up again shortly. When I log on, I get another dialogue box that tells me the computer is going to shutdown in 1 minute. Shutdown is initiated by NT Authority/System. It goes on to say the shutdown was due to Remote Procedure Call (RPC) service terminating unexpectedly. This happens immediately when I log on and I can't access anything in the 1 minute before the computer restarts. Prior to this, my computer worked great. I
    have Windows XP and automatic updates enabled. I was using McAfee virus protection and spyware protection. Thanks for your help!
     
  2. awalker0878

    awalker0878 Removed by request

    Joined:
    Dec 16, 2005
    Messages:
    407
  3. unbidden

    unbidden

    Joined:
    Jun 9, 2005
    Messages:
    1,469
  4. Kanester

    Kanester Thread Starter

    Joined:
    Jan 27, 2006
    Messages:
    3
    Folks,

    In the 1 minute I have to do anything, I opened task manager and checked that MSBlast.exe was not there. I think it needs to be listed for me to have that virus. Any other thoughts? Thanks again for your help.
     
  5. awalker0878

    awalker0878 Removed by request

    Joined:
    Dec 16, 2005
    Messages:
    407
    start\run: "SC failure rpcSs reset= 0 actions= ///" then run tool fully
     
  6. Kanester

    Kanester Thread Starter

    Joined:
    Jan 27, 2006
    Messages:
    3
    AWalker,

    The command kept the computer from shutting down. I ran the W32.Blaster.Worm tool and it ran for a while. Finally, it finished and said the Blaster Worm was not found on the computer. All the while the SVCHOST.exe errors kept popping up. I seem to think I screwed something up by rebooting before the Symantec software was finished loading. While I have the computer semi-working, do you think I should try to restore?

    Update: I uninstalled the virus software and it looks like things are back to normal. I'm gonna restore to the point just begore I tried to install the virus protection software and try to reinstall.

    Everything is working fine. Consider this problem solved. Thanks for your help! If I need to do anything (e.g. undo that command I typed in) just let me know. This help was definitely worth a donation!
     
  7. awalker0878

    awalker0878 Removed by request

    Joined:
    Dec 16, 2005
    Messages:
    407
    since you did a system restore before you ran the cammand you reset the RPC services failure options back to the default no undo command needed
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/437831

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice