Solved: Removable 'I' drive has gone missing

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Godmyeyesarebad!

Stuart
Thread Starter
Joined
Feb 26, 2008
Messages
170
Hello
I've just put a new blu ray reader/writer into the PC (Windows 7) and it all works well. But what has happened is that the external hard drive that previously had the letter 'I' allocated to it has now changed to 'J'. I've gone through the process of trying to rename it through the usual channels but the drop-down menu does not even show the letter 'I'. Is it possible to get it back or should I just stick with 'J'.
Thanks.
 
Joined
Jul 22, 2006
Messages
8,450
Sticking with J is the easy way out.
If you have a backup or sync program it may need to be adjusted
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top