1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Return without GoSub?

Discussion in 'Business Applications' started by maxx_eclipse, Jan 29, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. maxx_eclipse

    maxx_eclipse Thread Starter

    Joined:
    May 28, 2007
    Messages:
    291
    Morning all,

    I've just come across an error this morning when i was testing a macro in my database, when I was returned with the error: "Return Without GoSub".

    Anybody know what this means?

    The macro that returns this error is an OpenForm macro with the Where condition: ="[ID]=" & NZ([ID],0).

    What it basically does is allow the user to click on the ID of an entry, and the link will activate a new form window to load to the selected entry.

    This was working all wonderfully yesterday, and now it doesn't work anymore. I tried running an error check (Ctrl+Break) and also a 'Compact and Repair', but with no success.

    Any ideas what I can do?

    Help is much appreciated!
     
  2. maxx_eclipse

    maxx_eclipse Thread Starter

    Joined:
    May 28, 2007
    Messages:
    291
    Problem solved:

     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/795546