1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Saints Row The Third Major Lag. Don't know why.

Discussion in 'Games' started by BR4DMAN, Jul 13, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. BR4DMAN

    BR4DMAN Thread Starter

    Joined:
    Dec 28, 2011
    Messages:
    38
    Last night I bought Saints Row The Third and it downloaded and was ready about 2hours ago, So I loaded up the game and it was practically unplayable, the lag was terrible.

    But I also downloaded all the GTA's and I can run all of them fine, along with loads of other games, a few I can even run on ultra settings, but I can't even run Saints Row on the lowest settings, I know it's not because I have a 'bad computer' or anything like that because I went on YouTube and Someone has nearly everything the same as me in his computer build, but he can run the game on ultra settings, whilst I can't run the game on the lowest.

    So does anyone have any idea to why this might be? or any fix at all? I think I have updated all my drivers, I just got the latest amd catalyst update and I am using directX 11.

    I hope this can be fixed as I don't want to have just wasted my money on this game.

    Any help at all would be great!


    Graphics card : XFX HD Radeon 6770
    Motherboard: GA-970A-UD3
    CPU: AMD FX-4100 Quad Core 3.6GHz Bulldozer
    RAM: Corsair 8GB (2x4gb) DDR3 1866Mhz Vengeance Memory
    PSU: Corsair CX 600W V2 ATX2.2 80 PLUSĀ® Power Supply

    Here is the YouTube video of someone else close to my specs playing the game: http://www.youtube.com/watch?v=IVDUDw7z_i8
     
  2. BR4DMAN

    BR4DMAN Thread Starter

    Joined:
    Dec 28, 2011
    Messages:
    38
    Does no body have any idea at all?! Would updating my BIOS or updating my ATI chipset on the motherboard do anything?

    Come on, at least one person most have the same-ish problem? or at least an idea of how to fix it??
     
  3. BR4DMAN

    BR4DMAN Thread Starter

    Joined:
    Dec 28, 2011
    Messages:
    38
    I managed to fix it on my own, turns out it was a BIOS update that was needed.

    But thanks for all of your replies they were very helpfull - Oh wait, you didn't reply at all..
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1060824