1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Skype using 100% CPU

Discussion in 'All Other Software' started by Johnnyb2306, Jan 11, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Hi. I wonder if anyone can help me. I got a new Dell inspiron 1525 for Christmas, and am having a great time getting to know it. However, i'm sad to see i'm still having the same problem with Skype that i had on my last computer - namely, when I run Skype, it uses 100% of my CPU, making it difficult to use other programs at the same time. I know this isn't supposed to happen, and have read various potential solutions on different websites, but can't find a definitive answer about how to solve this. I'll be extremely grateful for any help, as I use skype everyday to talk to my fiancee.
    Thanks,
    John

    My specs are:
    Windows Vista Home Premium Service Pack 1
    Dell Inspiron 1525
    Celeron CPU 550 @ 2.00 GHz
    Memory 2.00 GB
    System Type 32 Bit Operating System
     
  2. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    Software limitations
    These program are known for causing problems, so if, please shutdown.
    The most common reason that Skype uses 100% CPU is the programs incompatibility with other software components often installed on PCs. For example programs such as
    Antivirus NOD32,
    recording software TotalRecorder,
    network monitoring software like Netlimiter and
    network "anonymizers" like
    Steganos Internet Anonymizer 5.0
    ZoneAlarm
    SpySweeper
    have been identified as causing problems when run simultaneously with p2p/voip software such as Skype.

    Also, be sure to turn off Windows XP speech recognition feature.
    The speech recognition engine kicks in when you begin a call and can cause your CPU to run at 100%.

    Turn off the speech recognition by opening the Control Panel and selecting
    Regional and Language Options. On the Languages tab, under Text services and input languages, click Details. Under Installed services, click Voice Recognition under the language you are using, and then click Remove.
     
  3. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Hi Karbo. Thanks for your reply.

    I'm not running any of the applications you listed. I use Avast antivirus, Comodo firewall, spybot (with teatimer) and spyware blaster. Could any of these be the culprit?

    I had a look at the speech recognition feature in Vista, but as it is asking me to configure it, i'm guessing it's not enabled. Obviously, the way you set this up differs from XP.
     
  4. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    Maybe Comodo?
     
  5. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    What's your version of Skype?
     
  6. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    It's version 3.8.0.180
     
  7. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    As for Comodo, I had the same problem with Skype on my old computer, which uses ZoneAlarm.
     
  8. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    Perhaps you should try the program after shutting down your firewall.
     
  9. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Thanks. I will try that and see if it helps.
     
  10. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Ok, I tried shutting down Comodo, and my CPU usage dropped to between 45 and 82%, which is great. Is it possible to configure Comodo so that it won't clash with Skype?
     
  11. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    I'm not familiar with Comodo settings. But there has to be a way to configure it so Skype can become a trusted application. You can try to make it less restrictive while you're using Skype.
     
  12. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Thanks. I'll try to find out how to configure Comodo. It's a lot more complicated than Zone Alarm.
     
  13. Johnnyb2306

    Johnnyb2306 Thread Starter

    Joined:
    Jan 9, 2009
    Messages:
    25
    Ok, I found out how to configure Comodo effectively. Unfortunately, it did not solve my problem of Skype causing my CPU to run at 100%. I uninstalled Comodo, and installed the PCTools firewall, which doesn't seem as good, but at least I can use Skype now without my computer giving trouble. The CPU is now between 55% and 85% with firefox running. So far, so good!

    Thanks for your help, Karbo. :)
     
  14. karbo

    karbo Banned

    Joined:
    Sep 2, 2003
    Messages:
    2,239
    Your welcome! :)
     
  15. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/789281