1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Solved: Event Log service failed; No network; Winsock reset doesn't help

Discussion in 'Windows 7' started by finnan, Sep 11, 2011.

Thread Status:
Not open for further replies.
  1. finnan

    finnan Thread Starter

    Joined:
    Sep 11, 2011
    Messages:
    1
    PROBLEM:
    Being a technician, I always have my Lenovo laptop running Windows 7 Professional x64, working perfectly and smoothly.
    One perfect day I installed Apple iTunes, rebooted my laptop and then I discovered that many services had stopped working:
    1. fingerprint logon failed (so I switched to entering password);
    2. very slow startup (up to 1 minute delay comparing with the time it normally consumes);
    3. NO Internet access at all: nor wireless neither wired;
    4. system message in notification area:
    5. Event Viewer (eventvwr.exe) could not start because of a problem with the service;
    6. In Services snap-in there were two services in uncommon state:
      Windows Event Log in Starting...
      TCP/IP NetBIOS Helper in Starting...
      both were holding infinitely.

    Of cause, first of all I uninstalled Apple iTunes, Bonjour (Apple service), QuickTime and other software I recently install.
    Didn't help.
    I tried Clean Boot, "sfc /scannow", System Resfore...
    Didn't help.

    I looked into Google for solutions. Many guys recommend to reset TCP/IP and Winsock with these commands (should be run under administrative account!):
    Code:
    netsh winsock reset
    netsh int ip reset
    It works for almost everyone with the same problem (so try it first!), but not for me and a couple of guys, because of the following error:
    Code:
    Initialization Function InitHelperDll in NSHHTTP.DLL failed to start with error code 11003

    SOLUTION:

    1. find a machine with the same OS;
    2. run regedit on that machine and export HKLM/System/CurrentControlSet/Services/Winsock and HKLM/System/CurrentControlSet/Services/Winsock2 into .reg files;
    3. run regedit.exe on your computer under administraive account;
    4. find and delete HKLM/System/CurrentControlSet/Services/Winsock and HKLM/System/CurrentControlSet/Services/Winsock2
    5. restore them by applying .reg files from a healthy machine;
    6. reboot;
    7. reset TCP/IP by executing two commands above;
    8. reboot againg;
    9. done!

    In case you have no healthy machine around, I attached my .reg files (for Windows 7 Pro x64) for your convenience.

    If it helps you - please, post a couple of words here! Thank you!


    P.S. Many thanks to adlep who post the main idea: http://forums.anandtech.com/showpost.php?p=27479319&postcount=1
     

    Attached Files:

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1017127

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice