1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Sony Vaio battery not recognized

Discussion in 'Hardware' started by Verlin, Oct 29, 2012.

Thread Status:
Not open for further replies.
  1. Verlin

    Verlin Thread Starter

    Joined:
    Oct 29, 2012
    Messages:
    2
    Sony vaio replacement battery not recognized?

    Tech Support Guy System Info Utility version 1.0.0.2
    OS Version: Microsoft® Windows Vista™ Home Premium, Service Pack 2, 32 bit
    Processor: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz, x64 Family 6 Model 15 Stepping 13
    Processor Count: 2
    RAM: 3061 Mb (All 4GB recognized by Vista, not BIOS)
    Graphics Card: Mobile Intel(R) 965 Express Chipset Family, 448 Mb
    Hard Drives: C: Total - 74816 MB, Free - 10203 MB; D: Total - 870 MB, Free - 224 MB; E: Total - 1749 MB, Free - 609 MB; F: Total - 2831 MB, Free - 428 MB; G: Total - 14315 MB, Free - 3748 MB; H: Total - 74811 MB, Free - 11524 MB;
    Motherboard: Sony Corporation, VAIO
    Antivirus: Microsoft Security Essentials, Updated and Enabled.

    got a replacement battery and a different original from a computer bought at same month when the initial one became a brick for some undetermined electrical charging problem. Initially, if the larger generic replacement stopped being recognized, I could put in the other original and the system would reset. After a night when the hibernation file was deleted (now restored), and the batteries changed, the unit has never recognized either battery. The complaint is the same as this prior : It shows that there's a battery there when I plug it in, and will power the computer when I unplug the power supply. However, my orange battery light blinks very rapidly, nonstop and the batter will discharge but not charge. Should I turn off my computer, it will not turn on unless I unplug the battery. The orange battery light lights up and continuously blinks if I try to start the unit, but it will not start until I remove the battery. It will turn on with AC power alone. Inserting the battery after turning it on induces the situation I described first- can see that battery is there, but it won't charge, and the light blinks. The battery models are vgp-bps9/s and vgp-bps9. I can put both into the other computer unit used by my son and they will charge, but we both fear making his system not work - so I just work on electrical power only attached to a UPS when home not working in villages.

    Some online discussion read months ago said something about opening the unit and detaching the bios wire from the mother board battery, or something like that, to fix the problem. I cannot refind the post. Any ideas?

    While waiting for a real answer, I have blocked the ISBMgr.exe in registry by replacing with 'Version.txt' of same directory. Actual advice from YouTube Video was to remove registry entry. (http://www.youtube.com/watch?v=FTjSDM0AjxU)

    The batteries still will not start or let the computer work nor recharge though, as previously described.

    thanks for any help.:D
     
  2. Verlin

    Verlin Thread Starter

    Joined:
    Oct 29, 2012
    Messages:
    2
    This problem solved by two steps:
    1) replacing the ISBMgr.exe in registry with the 'Version.txt' stopped the ISBMgr file from working AND notifies me of the registry switch to be corrected later by showingup on boot, but
    2) using device manager to delete Microsoft ACPI-Compliant System from the System category of devices seems to have re-initiated the entire system.

    On deletion of Microsoft ACPI-Compliant System, I had to be ready to replace the video driver; all the other drivers seem to have been found automatically.

    Both portable batteries now charge and are charged. The system boots by battery; operates on battery.

    The system hibernates correctly after having followed instructions to rebuild hibernation file by
    using an administrator command prompt, & typing:
    powercfg /hibernate on
    followed by a computer restart.

    I also fixed the power settings to protect hibernation by following these instructions on all power settings:
    •Click “Change advance power settings”
    •Scroll to and expand the “Sleep” option.
    •Select “Off” to the “Allow hybrid sleep” option.
    •Scroll to and expand the “Power buttons and lid” option.
    •Select “Hibernate” for the “Sleep button action” option. 10. Select “Hibernate” for the “Start menu power button” option.

    The VAIO VGN-CR320E now uses its battery function as it should. I continue to get the text at start up for having replaced ISBMgr.exe in the registry with Version.txt. I have not yet decided to delete the entry completely or return it to ISBMgr.exe and see what happens.

    Hope this helps someone else as it appears I found and fixed it myself unless someone can add to my knowledge.

    Thanks for reading.:cool:
    Verlin

     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1074571

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice