1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Sony VAIO video controller driver

Discussion in 'Hardware' started by Islandboy, Sep 30, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    I have a Sony VAIO PCV-RX741 (XP Pro SP2) that I had to reinstall the OS and clean up. Most everything has come back fine except my monitor (cannot go above 800x600 res even though it supports 1024x768) i believe the problem is the video controller driver is not installed.

    I downloaded and used the drivershq.com driver detective and it downloaded sis_v614103671_64bit.zip which contains a setup for this driver, however the UseDLL failed causing two dll's not to load...(SisBase.dll and SisParse.dll) so the installation stops...any ideas?

    Can anyone assist?
     
  2. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
  3. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    thanks, but i downloaded what they had and the video controller driver was not there
     
  4. colmaca

    colmaca

    Joined:
    Jul 11, 2003
    Messages:
    1,429
  5. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    i downloaded that one, but in device mgr the video controller still shows as no driver...driver detective app still locates video controller has having no driver...can someone help me troubleshoot how to get the correct driver installed?

    I believe if someone could either help me with the correct driver OR help me resolve the UseDLL failure i could resolve the problem
     
  6. colmaca

    colmaca

    Joined:
    Jul 11, 2003
    Messages:
    1,429
    Did you get any error when you installed the above SIB07CXDDZ.EXE ?
     
  7. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    no, I rec'd no error, rebooted and still the no driver indicator

    I've now tried to reinstall it 3times and here's an interesting message i get each time during the install: "This software driver has never been installed in your computer system. Would you like to continue the installation?"
     
  8. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
    Did you or any anyone else change any hardware in the system?

    Download Everest: http://www.majorgeeks.com/download4181.html
    Look under the Display -> GPU section or the Devices -> Physical Devices section to see what it says your video adaptor is.
     
  9. fleamailman

    fleamailman

    Joined:
    Oct 3, 2005
    Messages:
    547
    Hi, drop the resolution to high(24bit) that will give you the new option of 1024 by480, press apply. I think I have the same model and did the same thing.
     
  10. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    Actually i only have the option of highest and medium - but i get the 1024 x 768 option on both...when i apply it says out of range
     
  11. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    I'll run this in about an hour and post my findings...thanks
     
  12. Triple6

    Triple6 Rob Moderator

    Joined:
    Dec 26, 2002
    Messages:
    45,618
    You may need to install teh monitor drivers if they exist. Usually you don't have to but maybe in this case it will help - Its the monitor INF on the Sony site. It has to manually installed by updating the monitor driver.
     
  13. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    yeah, i installed all available drivers from the sony site...still nothing
     
  14. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    Everest showed this under physical devices > SiS 315 Integrated Video Adapter

    I've been trying to install the driver via this executable...SIB07CXDDZ.EXE - is there an actual driver file w/o the executable i can get and point to for install instead?

    I also attempted to download the driver found on http://www.sis.com/download/
    However, upon attempting to run the setup program within the zip file, i rec'd the msg - cannot find suitable driver and the set up auto cancelled.

    Please help.
     
  15. Islandboy

    Islandboy Thread Starter

    Joined:
    Feb 19, 2005
    Messages:
    63
    I resolved this by locating a SiS 650 driver which for whatever reason when installed as part of SiS utility resolved my problem.

    Thanks for all your suggestions
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/505585