1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Sony Windows 8 Refresh Caused Access Denied Error on C:\

Discussion in 'Windows 8' started by dollarbillme, May 13, 2013.

Thread Status:
Not open for further replies.
Advertisement
  1. dollarbillme

    dollarbillme Thread Starter

    Joined:
    Oct 29, 2007
    Messages:
    6
    Sony Windows 8 Refresh Caused Access Denied Error on C:\

    I am creating this post as I found no working solution using Google.

    First some background:

    I was working with a customer machine infected with the FBI (Money Pack) virus. The computer was a Sony AIO with Windows 8, UEFI, and GPT. I was unable to run any programs in normal mode. I was also unable to open safe mode. In addition, due to the GPT file system, I was unable to pull the hard drive and scan it in another system. Furthermore, the computer would not boot from Hirens and a Windows install disk caused it to lockup. I was able to run System Restore, but it failed before completing.

    Thus I tried the option labeled “System Refresh”.

    System Refresh completed fairly quickly without error, and upon competition the virus pop-up was gone. Also the user’s desktop icons were intact. I found however that I could not access their personal folders. When I clicked on C:\ I was given a simple “Access Denied” message. To make matters worse, I could run a cmd prompt, but not an administrator cmd prompt. Task Manager would not load as well.

    I did first try taking ownership of C:\ and resetting permissions but this made matters worse and I had to perform a second Refresh to undo that mess. The computer had only 1 user account and I could not verify the issue was related to the profile or not. Also, I could not create a new account as the Metro PC Settings menu was blocked as well.

    I found the solution in booting to Safe Mode (shift + restart) and first activating the hidden administrator account.

    Using the user account in Safe Mode, I could open an administrator cmd prompt.

    I then used “net user administrator /active:yes” to enable the hidden admin account.

    Next, logged out of the user account and logged in as admin while still in safe mode. Using the admin account I was then able to access Metro’s PC Settings and create a new user account.

    I then rebooted the computer and logged in as the new user. The new user account worked properly and did not suffer from the “access denied” errors.

    I then copied the user’s files from the profile on the C:\ drive to new account and deleted the broken account.

    In my experience the issue was simply a “corrupted profile” but due to Windows 8 the fix was much more difficult to perform.

    To recap

    1. Boot to Safe Mode using Shift + Restart
    2. Enable hidden Admin account using “net user administrator /active:yes”
    3. Create new user
    4. Copy files from broken account to new

    I hope this helps others, and is yet another proven reason why I hate Windows 8.
     
  2. gurutech

    gurutech

    Joined:
    Apr 23, 2004
    Messages:
    2,960
    The Access Denied may have just been a fluke in the initial installation. I just cleaned up one of these FBI viruses the other day, and was able to do a system restore with no problems.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Solved Sony Windows
  1. ron derenzo
    Replies:
    4
    Views:
    269
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1098617