1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: Speed Up My Processor!

Discussion in 'Windows XP' started by chow2rich, Jan 22, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. chow2rich

    chow2rich Thread Starter

    Joined:
    Jan 10, 2007
    Messages:
    114
    Is there a way I can speed up my computer once the computer starts up ,shutdown and even playing games? I have too many items on my startup tray, but I need those. I have a laptop that is Toshiba Intel Centrino Duo Core, 1.5 GB of RAM, Harddrive Capacity 150 GB, and 1.6 GHZ. But somehow the computer is still kinda of slow. Thanks! (y)
     
  2. steven1350

    steven1350

    Joined:
    Jun 3, 2006
    Messages:
    862
    It is possible to upgrade certain components of a laptop. However, with those specs, it should run smoothly. I presently am using a Core 2 Duo 1.6GHz, 1GB RAM, and everything seems fast.

    Are you running games on batteries. Many laptops deliberately lower their clock speeds when using a battery so it can save power. Make sure its plugged in.

    If your feeling rich, try adding more RAM, you dont really need the upgrade, but more ram never hurt anyone
     
  3. chow2rich

    chow2rich Thread Starter

    Joined:
    Jan 10, 2007
    Messages:
    114
    Thanks for your help. I appreciate it. But somehow it's still kinda slow sometimes, can you tell me why? My processor sometimes goes up to 1GB of Ram in the PF Usage and the CPU usage is 20% or 30%. And I wasn't playing games with batteries. I was plugged in. But other times it was really quick loading my windows. (y)
     
  4. chow2rich

    chow2rich Thread Starter

    Joined:
    Jan 10, 2007
    Messages:
    114
    Oh, by the way can you help me with this problem too? Each time my computer starts up, AOL also starts-up. But I told it not to put it in the start-up tray, but it's still there and running. I don't have the CD for it, and was pre-installed when I got the Laptop. I think it's something to do with my Internet connection, but when I keep checking on it its fine, everything looks fine. I have dialup, used to have DSL broadband. But anyway each time my computer starts-up so does AOL. And also I think thats whats effecting my CPU usage and PF Usage. Can you help me please! Thanks! (y)
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/537552

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice