Solved: Start-up error.... Failed to start the X server (Linux Mint 14 Cinnamon)

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
I am new to all this, but I've managed to install Linux Mint 14 (Cinnamon) on my netbook and when I choose Linux Mint in the OS options screen at start -up, I get this message:
"Failed to start the X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?"
When I choose Yes, I get a string of info then
"Fatal Server Error: no screens found.
Server terminated with error (1). Closing log file."
The next window would show me more info, then I get
"The X server is now disabled. Restart MDM when it is configured correctly."

Could anyone help me out with this?
 
Joined
Jun 11, 2004
Messages
3,888
This is a standard case of Linux Mint fails to match your graphic card. Happens all the time as Linux does not ask for the video driver and the installer could have picked a wrong one.

You can get into the terminal mode by ctrl+alt+F1

You can become a root user in a terminal by command
Code:
sudo -i
and stop the xserver by command
Code:
service kdm stop
you can then generate your own xserver configuration file by command
Code:
Xorg:1 -configure
since you are in root this file is stored in /root and call xorg.conf.new which you have to put it in the /etc/X11 directory by copying it over with the command
Code:
cp /root/xorg.conf.new /etc/X11/xorg.conf
Then you can restart xserver by
Code:
service kdm start
If the problem persists you then have to do a crtl+alt+F1 once more. This time you get into root and edit xorg.conf by command
Code:
nano /etc/X11/xorg.conf
Try to change the driver to vesa or nv etc to get over the problem.

As an example I post a section of my /etc/X11/xorg.conf as below where I highlighted the video driver "nvidia" in blue.
Code:
Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "WrappedFB"          	# [<bool>]
        #Option     "GLXVBlank"          	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
 #"nouveau"
    Identifier     "Card0"
    Driver         "[B][COLOR="Blue"]nvidia[/COLOR][/B]"
    BusID          "PCI:2:0:0"
EndSection
To change the video driver to vesa, a generic driver works for most graphic card, is now depicted in red below
Code:
Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "WrappedFB"          	# [<bool>]
        #Option     "GLXVBlank"          	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
 #"nouveau"
    Identifier     "Card0"
    Driver         "[B][COLOR="Red"]vesa[/COLOR][/B]"
    BusID          "PCI:2:0:0"
EndSection
In LInux if you are prepared to get your hand dirty you can solve a lot of problem yourself. All the above can be found by Google.
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
Thank you for your reply!
I am sorry but I am very new to this so this may be a stupid question.
Do I get into the terminal mode when the X server error comes up? I tried doing this but when I type "service kdm stop" I get the message "kdm: unrecognized service" and the rest of the command doesn't work (Xorg:1 command not found etc)
When I type the "nano /etc/X11/xorg.conf" I get a black screen with some buttons at the bottom - what do I do here?
Again thank you for your help!
 
Joined
Jun 11, 2004
Messages
3,888
Did you follow the instructions one step at a time?

You can always jump into a terminal mode by the first step above by pressing ctrl+alt+F1 keys. To jump back is by pressing ctrl+alt+F7.

Linux reacts differently to root user and ordinary user so the command "sudo -i" is needed to become the root user before other commands.

As a test to see if you are in a terminal mode you can list the Linux directory as any user in terminal mode by command
Code:
ls -l
to see if you are root or not try this command which list all the hard disks and partitions
Code:
fdisk -l
More than 50% of the power of Linux is available only at the terminal so lose nothing by trying to understand it.
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
Did you follow the instructions one step at a time?

You can always jump into a terminal mode by the first step above by pressing ctrl+alt+F1 keys. To jump back is by pressing ctrl+alt+F7.

Linux reacts differently to root user and ordinary user so the command "sudo -i" is needed to become the root user before other commands.

As a test to see if you are in a terminal mode you can list the Linux directory as any user in terminal mode by command
Code:
ls -l
to see if you are root or not try this command which list all the hard disks and partitions
Code:
fdisk -l
More than 50% of the power of Linux is available only at the terminal so lose nothing by trying to understand it.
Yes, I have pressed ctrl+alt+F1 and what I get is a black screen where I can type commands:

"Welcome to Linux Mint 14 Nadia (GNU/Linux 3.5.0-17-generic i686)
Welcome to Linux Mint
*Documentation: http://www.linuxmint.com
[email protected] ~$"

I type sudo -i and "mint ~#" comes up in red
Then I type "service kdm stop" and it returns "kdm: service unrecognized".
"cp /root/xorg.conf.new /etc/X11/xorg.conf" would give me /root/xorg.conf.new not found
and xorg.conf doesn't exist in /etc/X11/.

Test if I am in terminal mode:
"ls -l" returns "total 0"
"fdisk -l" returns info about disk, "Disk /dev/sda..." Device Boot, Start, End, Blocks, Id, System etc.

I'm sorry I'm such a computer noob.

(Edit:
I have also tried this method on this forum, http://forums.linuxmint.com/viewtopic.php?f=46&t=105156
1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx

I'm not sure if it applies to what I'm using, but when I type sudo Xorg -configure, I get "Number of created screens does not match number of detected devices. Configuration failed. Server terminated with error (2). Closing log file." and this method does not work.
Although I'm not sure what this means.)

Info about my graphics card:
00:02.0 Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev09)
I don't think I have Nvidia

I have tried reading around on google but nothing seems to be working.
Thank you so much for your help
 
Joined
Jun 11, 2004
Messages
3,888
Good news as you can get a shell using ctrl+alt+F2. In fact 4 shells are availabe between F1 & F4. Just use any one.

In Mint you can prefix every command with "sudo" to claim root or just do it once with "sudo -i". The changing of colour denotes the change of status.

You might try
Code:
Xorg:1 -configure
instead of
Code:
Xorg -configure
as the former is newer. The kernel might have changed to respond differently. Only after xorg.conf generated successfully should you copy it.

In your xorg.conf you will see what driver Mint has selected for you.

It is a common problem for a Linux installer to mismatches the driver because graphic card vendors do not supply the latest drivers to Linux (mainly to MS Windows) or make their drivers complying with the standard.

In general you should get the system up and running in the end but you do learn a lot of how to configure your display.
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
Good news as you can get a shell using ctrl+alt+F2. In fact 4 shells are availabe between F1 & F4. Just use any one.

In Mint you can prefix every command with "sudo" to claim root or just do it once with "sudo -i". The changing of colour denotes the change of status.

You might try
Code:
Xorg:1 -configure
instead of
Code:
Xorg -configure
as the former is newer. The kernel might have changed to respond differently. Only after xorg.conf generated successfully should you copy it.

In your xorg.conf you will see what driver Mint has selected for you.

It is a common problem for a Linux installer to mismatches the driver because graphic card vendors do not supply the latest drivers to Linux (mainly to MS Windows) or make their drivers complying with the standard.

In general you should get the system up and running in the end but you do learn a lot of how to configure your display.
Thanks, I was wondering wha the difference was with F1 and F2.

I tried doing both Xorg and Xorg:1 and it returns me command not found..
 
Joined
Jun 11, 2004
Messages
3,888
Xorg is in /usr/bin subdirectory which you can ckeck its presence. You need to be in root (as an Admin) to issue this command.
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
Xorg is in /usr/bin subdirectory which you can ckeck its presence. You need to be in root (as an Admin) to issue this command.
Ah, indeed I did find it. I managed to type "Xorg -configure" then get a long list of video drivers and an error saying "Number of created screens does not match number of detected devices. Configuration failed. Server terminated with error (2). Closing log file."....

I copied the /root/xorg.conf.new to /etc/X11/xorg.conf anyway, then did the nano thing and I got
4 device sections (drivers are intel, modesetting, fbdev and vesa). I also have 4 screen sections (screen0, screen1, screen2 and screen3).

Should I try changing all drivers to vesa?

Again thank you so much for your help...
 
Joined
Jun 11, 2004
Messages
3,888
The new xorg.conf does crazy thing like creating a configuration file assuming a user has 4 screens. It does this for both of my Ubuntu and Mint.

You can either change all of them to vesa or put a # in front of the lines to disable the irrelevant sections if you are confident of locating the start and the end of each section. If vesa doesn't work try fbdev.
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
The new xorg.conf does crazy thing like creating a configuration file assuming a user has 4 screens. It does this for both of my Ubuntu and Mint.

You can either change all of them to vesa or put a # in front of the lines to disable the irrelevant sections if you are confident of locating the start and the end of each section. If vesa doesn't work try fbdev.
Thanks! I have had a look at "How do I configure an xorg.conf file?" on https://wiki.ubuntu.com/PowerPCFAQ
and deleted unnecessary subsections and edited ServerLayout so that I was left with one device, one monitor and one screen. It still told me that the number of created screens does not match...
I changed the screen to vesa, still tells me the same error, and when I run "startx" (because "service kdm restart" does not work) I get a blank screen with a white flickering underscore on the top left and is staying like that forever. I force reboot and everything goes back to the way it started...

Edit:
Then I tried it with fbdev. I used startx command and I got into linux mint for the first time (YAY) :). However I seem to be logged in as root and when I log out I get the black terminal-like screen again. When I shut down I need to configure nano Xorg all over again... so the question is how do I begin using the OS normally so the settings etc is saved?
 
Joined
Jan 13, 2013
Messages
2
I had a similar problem... following the above steps I could successfully start the X gui... but now the same issue reappears after I reboot. how do I make the changes permanent ?
 
Joined
Jun 11, 2004
Messages
3,888
When you edit the \etc\\X11\xorg.conf you have to save the file. Once saved the configuration file will be used permanently.

The \etc\X11\xorg.conf is a system file and you should expect the kernel to disallow ordinary user to change it. Thus you must be in root to edit it. After edit and start X from the terminal you are still in root. However once reboot you should go back to the ordinary user mode.

Older Linux permit a user to log into desktop as a root user especially the Slackware and Slax families. Modern version prefer only normal users in desktop. Terminal mode is always available to root user and has never changed.

If you use Linux go with the trend as that is the best approach established by the community. M$ systems actually follow Linux trend on security and their modern Windows have file ownership same as Linux.

There is no doubt in my mine that a Linux user is one who not only operating the system but has an interest in its inner working. Linux knowledge is open source so all the knowledge is in the public domain. Many things in Linux can therefore be "reasoned" out. Any knowledge in a Linux terminal will stay with you forever as the kernel does not get changed like a MS Windows. It only get refined.

If you want how things work in a computer and do not mind getting your hand dirty Linux will be the one for you.
 
Joined
Jan 13, 2013
Messages
2
If /etc/X11/xorg.conf is a system file then it should be present by default, but initially it doesnot exist.
After I copy it from /root/xorg.conf.new, I edit the /etc.. file replacing 'intel' with 'vesa'. Then I save the file and 'startx'
GUI starts okay.
I reboot the PC, and back to square one!
Please help!
 

wakki

Thread Starter
Joined
Jan 7, 2013
Messages
14
When you edit the \etc\\X11\xorg.conf you have to save the file. Once saved the configuration file will be used permanently.

The \etc\X11\xorg.conf is a system file and you should expect the kernel to disallow ordinary user to change it. Thus you must be in root to edit it. After edit and start X from the terminal you are still in root. However once reboot you should go back to the ordinary user mode.

Older Linux permit a user to log into desktop as a root user especially the Slackware and Slax families. Modern version prefer only normal users in desktop. Terminal mode is always available to root user and has never changed.

If you use Linux go with the trend as that is the best approach established by the community. M$ systems actually follow Linux trend on security and their modern Windows have file ownership same as Linux.

There is no doubt in my mine that a Linux user is one who not only operating the system but has an interest in its inner working. Linux knowledge is open source so all the knowledge is in the public domain. Many things in Linux can therefore be "reasoned" out. Any knowledge in a Linux terminal will stay with you forever as the kernel does not get changed like a MS Windows. It only get refined.

If you want how things work in a computer and do not mind getting your hand dirty Linux will be the one for you.
Though Linux Mint could just be a simple, hassle-free and fit-for-beginners OS to use on slow netbooks, without the need to tamper with the system if it doesn't take soo much effort to install... >.<

I have the same problem, I edit xorg.conf using nano /etc/X11/xorg.conf, exit and say yes to save changes (under same file name). Whether or not I "logout" root before "startx", when I reboot I am back to square one, where I get the error message "failed to start the X server" and I have to copy, edit etc again.

:(
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top