Solved: Strong network signal but can’t connect

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

klaatu

Thread Starter
Joined
Sep 11, 2007
Messages
73
I just installed a D-Link wireless router (DI-524). The network shows up with a strong signal when I do a site survey from my laptop (Dell Latitude D400), but it won’t connect to it. I’ve tried connecting using both the PC’s built-in wireless card and also the USB wireless adapter (DWL-G122) that came with the D-Link kit, with no luck. Other relevant facts:

--I have no trouble connecting to other networks with the built-in wireless card
--Tried changing my network's channel; didn't help
--I’m sure I typed the WEP encryption key correctly
--Laptop is only 3 ft. from the router, no barriers or interfering devices present (2.4Mhz phone, monitor, etc.)
--Router has the latest firmware upgrade
--Tried several network mgt. utilities (Dell’s, D-Link’s AirPlus, Network Magic), including their “repair network” features

I’m stumped. Can anyone suggest anything else I might try?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
Disable encryption and see if it connects. Note that you should ALWAYS use only the HEX key option for WEP, because different equipment generates different keys with the passcode option.
 

cwwozniak

Chuck
Trusted Advisor
Spam Fighter
Joined
Nov 28, 2005
Messages
66,433
Hi klaatu, and welcome to TSG.

Did you you set up a new unique SSID name for the wireless connection? If it is still set factory default, you can not 100% sure you not attempting to connect to a neighbor's wireless network with the same default name.

Temporarily disable all encryption on all wireless devices and see if you can connect. If supported, use WPA with a long password that can not be easily guessed. The last that I read, WEP can easily be cracked in a matter of minutes. WEP will only help to keep honest people from accessing your wireless network.

EDIT: Looks like JohnWill can type faster than me.
 

klaatu

Thread Starter
Joined
Sep 11, 2007
Messages
73
Thanks, JohnWill & cwwozniak. To answer your questions:

--I did assign a unique SSID name
--I was using HEX encryption for WEP

I tried disabling WEP and then connecting per your suggestion, but no luck. My wireless utility reports:

Signal: Excellent
Status: Acquiring network address…
-- and then a short time later:
Status: Limited or no connectivity

It still won't connect. Anything else I could check/try?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
Do any wireless machines connect to the router? Did you change channels on the router?
 

klaatu

Thread Starter
Joined
Sep 11, 2007
Messages
73
JohnWill said:
Do any wireless machines connect to the router?
No. I've only tried connecting from my laptop, and I'm not aware of any intruders accessing it.

JohnWill said:
Did you change channels on the router?
Yes. The default was 6; I changed it to 1 when I couldn't connect. It's still at 1 (after disabling WEP).
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,751
When you configured the router you didn't enable MAC address filtering or disable the Dhcp server or severely restrict its address space, right? Can you connect the laptop via ethernet and try wireless and show ...

Start, Run, CMD, OK to open a command prompt:

Type the following command:

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If necessary use a text file and removable media to copy the results to a computer with internet access.
 

cwwozniak

Chuck
Trusted Advisor
Spam Fighter
Joined
Nov 28, 2005
Messages
66,433
Are you using DHCP on the computer to get your IP address, If so, do you have DHCP enabled on the Router?

Do you have any kind of MAC filtering turned on in the router wireless settings?
 

klaatu

Thread Starter
Joined
Sep 11, 2007
Messages
73
TerryNet said:
When you configured the router you didn't enable MAC address filtering or disable the Dhcp server or severely restrict its address space, right?
Aha! I didn’t touch the default MAC filtering setting, which is “only allow computers with MAC addresses listed below to access the network.” At first I assumed that should be fine, since the two addresses in the filter list are the MAC addresses of my desktop & laptop (both originally connected via Ethernet). Then I realized that's just my laptop's Ethernet card's MAC address, not its wireless card's address. So I disabled MAC filtering completely, and voila -- I was able to connect. Then I turned WEP encryption back on, entered the key on my laptop and that now is working too. Many thanks -- you guys are great!

I'm sorry to hear that WEP encryption is easily cracked. (Probably even more of a danger here in Silicon Valley where I live.) I only intend to use my wireless network on rare occasions, when I want to use my laptop on my patio. So I'll just turn off the wireless on my router other times, to reduce vulnerability. But let me ask this: if I entered my laptop's wireless adapter's MAC address on my router's exception list, and turned “only allow computers with MAC addresses listed below to access the network" back on, would that prevent others from hacking my network, even if they were able to crack the encryption key?
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
Since both units support WPA, why not change your encryption to WPA and use a long and random key? That way you can safely leave the wireless on all the time, there is no known crack for WPA with strong passwords. You can also dispense with other anemic protections such as MAC address filtering and SSID hiding, since they're not doing anything but making it harder for you to use your network. :)
 

klaatu

Thread Starter
Joined
Sep 11, 2007
Messages
73
Done -- changed to WPA. I also made a donation to the site. You guys are great! (y)
 

JohnWill

Retired Moderator
Joined
Oct 19, 2002
Messages
106,425
Glad we could help. :)

You can mark your own threads solved using the thread tools at the top of the page in the upper right corner.© :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top