Solved: Synology NAS external access

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
Hi, I am trying to set up a Synology NAS DS212j to have remote access. I'm using a Netgear DG834PN router, trying to host it via a no-ip.com DDNS.

In trying to get it set up manually every time I tried the no-ip.com account it would give me remote access to the router not the NAS unit.

Following the EZ-internet wizard to set it up the DDNS info on the NAS unit finds the gateway info but lists the status of the DDNS as "Forwarding. Please wait..." (waited for an hour no change). When trying to access the no-ip.com account it times out saying the server is taking to long to respond.

I have been using the following to try and set it up -
http://forum.synology.com/wiki/index.php/Remote_Access_on_the_Synology_DiskStation
http://www.networkedmediatank.com/wiki/index.php/Network_Synology_NAS_setup

On the router I changed the DHCP range to 192.168.0.2 - 192.168.0.240 and set the NAS IP to 192.168.0.250 (static internal IP?)

I forwarded port 80 via the EZ-internet wizard as demonstrated by the first link above.

Thanks for any help you can provide, if you need any more information just let me know what you need.
 
Joined
Aug 30, 2012
Messages
893
Synology needs too many ports to forward, your router won't let you do that. Try setting Synology as DMZ host.
 

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
Humm.. The router is on their supported list and most if not all set-up guides say you only need port 80 to be able to access it.

How do you set up the synology as DMZ host and isn't that a big security issue??
 
Joined
Aug 30, 2012
Messages
893
Just to access web interface port 80 is enough, for other features you need corresponding ports. Go to this site and see how to manually forward ports on your router and forward port 80. Disable WAN side management on your router. Go to this site to check if you did all right. Only setup DDNS when you can get into NAS using public IP.

Being connected to Internet, opening (forwarding) ports and setting up DMZ host is all considered security risks. Strong passwords should always be used.

Instructions on DMZ setup should be in your routers manual.
 

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
When you say go to this site... Do you mean techguy or are there meant to be links there?
 

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
I checked the port using CheckMyPort.com and it lists port 80 as open

The no-ip.com address still give the took too long to respond message.

The DDNS settings page on the NAS now lists the status as "Normal", yet still no luck connecting to it.
 

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
I've gone through and as far as I can tell I've forwarded port 80, 5000, etc to the NAS unit. However, when ever I try the DDNS address it just logs me into the router.

Anybody know why this is and how to fix it? Have I missed something?
 
Joined
Apr 23, 2004
Messages
2,960
Your ISP may be blocking port 80. I know my ISP does. You may be able to set no-ip.com to use a web forwarder to point to a different port number, such as 8080, and then from your router forward port 8080 (external) to port 80 (internal) to the Synology.

So for instance, browsing to http://dougx789.no-ip.com will automatically forward to port 8080 on your router (bypassing the "block" by the ISP), and then your router takes all traffic sent to port 8080 from the outside to port 80 internally (where the Synology is listening).
 
Joined
Aug 30, 2012
Messages
893
When you say go to this site... Do you mean techguy or are there meant to be links there?
There supposed to be a link.
How do you know you've forwarded ports right? Can you get into NAS by using your external IP address?
Also, try to access it from outside your LAN, use a smartphone or ask a friend, since requests using public IP to your local devices may be blocked by your and/or ISP firewall.
When you try plain DDNS address, it by default uses port 80 (HTTP). If you want to access different port you should address it like that: yourddnsaddress:portnumber
 

Dougx789

Thread Starter
Joined
Apr 6, 2010
Messages
619
Thanks for the replys

Turns out the Synology EZ-internet wizard wasn't able to forward the ports correctly, so I removed all the settings it had done and manually did the lot. Now up and running.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top