Solved: Task bar buttons aren't working

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

MallyMcGinnis

Thread Starter
Joined
May 26, 2011
Messages
63
Using Windows XP Pro with SP3. TSG SysInfo output below.

Yesterday, I noticed I noticed that when I clicked left or right mouse buttons on a particular icon in my task bar (or is it the system tray), nothing happened; no menu, no app. No problem with tool bar, nor desktop shortcuts. I didn't worry about it as I could access that app another way, and just thought the system needed to be rebooted. When I was done working on what I had been doing, I rebooted...to a totally blank (except my old desktop image); no tool bar, no start button, no desktop icons...nothing.

I decided to try to see what Windows Task Manager (Ctrl+Alt+Del) might tell me. There were the usual 3 applications running, and the typical longer list of processes. Since one of the apps already running was Firefox, I right clicked it, and selected "maximize", did some poking around, and found the best thing at that point would be to do a system recovery. I did to a set point I made the night before, and everything on my desktop looked normal again. But still, the task bar icons were and remain dead.

I had been working on removing old, broken, or otherwise useless registry keys using PC Health Advisor, and did make a back up of the registry before starting the software; I had suspected a virus or malware (used Malwarebites Anti Malware to screen for these, not that I could tell you the difference between malware and a trojan anyway), and wanted to make sure it hadn't infected my registry. It found hundreds of errors, and fixed them. It's possible that's when I knocked out the functionality of those buttons, but am not keen to restore the registry to where it was before I cleaned it for concern of bringing back any infections.

I spent many hours last night and this morning Googling for help, but am not finding anyone with quite the same problem. To be clear, the area I refer to is where the clock can be found, on the lower right of my screen. Here's an image:
.

So, how might I proceed to locate and repair my issue?

Tech Support Guy System Info Utility version 1.0.0.1
OS Version: Microsoft Windows XP Professional, Service Pack 3, 32 bit
Processor: Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz, x86 Family 6 Model 15 Stepping 13
Processor Count: 2
RAM: 2046 Mb
Graphics Card: NVIDIA GeForce 8800 GT, 512 Mb
Hard Drives: C: Total - 28003 MB, Free - 8866 MB; D: Total - 29996 MB, Free - 10243 MB; E: Total - 180464 MB, Free - 38790 MB; F: Total - 38154 MB, Free - 15355 MB;
Motherboard: Foxconn, 45CMX/45GMX/45CMX-K, , UYRL81513187
Antivirus: avast! Antivirus, Updated: Yes, On-Demand Scanner: Enabled
 

fairnooks

Banned
Joined
Oct 1, 2007
Messages
5,251
You might try creating a new profile and see if everything is functional there, and if it is move to it and abandon the damaged one.
Otherwise its probably more trouble than its worth and too time consuming to try and figure out what is the problem and what the remedy is.
System restore to a point before the problem despite the possibility of getting infected again is the route I would go and then scan with Malwarebytes and others to detect and remove any virus.
 

Phantom010

Retired Trusted Advisor
Joined
Mar 9, 2009
Messages
34,801

MallyMcGinnis

Thread Starter
Joined
May 26, 2011
Messages
63
Thanks, fairnooks; I'll try creating a new profile, then building from there if I have success. If that fails, I'll go back in time to find a set point that does resolve it, if it's resolvable.
 

Phantom010

Retired Trusted Advisor
Joined
Mar 9, 2009
Messages
34,801
Thanks, fairnooks; I'll try creating a new profile, then building from there if I have success. If that fails, I'll go back in time to find a set point that does resolve it, if it's resolvable.
Start fresh by not reinstalling registry cleaners... ;)
 

MallyMcGinnis

Thread Starter
Joined
May 26, 2011
Messages
63
Phantom, that wasn't helpful. I've never understood negative personalities like yours.

You may be correct, that my OS is hosed, but I think reinstalling it and all my software and data should be considered a last step, not a first just to make a point about your disdain for registry cleaners.
 

Phantom010

Retired Trusted Advisor
Joined
Mar 9, 2009
Messages
34,801
Actually, my advice about staying far away from registry cleaners is shared by most forum members here, and will be one of the best you'll get to avoid a similar problem in the near future...

That being said, try the Taskbar Repair Tool Plus.
 

MallyMcGinnis

Thread Starter
Joined
May 26, 2011
Messages
63
Thanks for the repair tool link, Phantom. It didn't solve my issue, but it's a cool little utility just the same.

I did fix the problem, however, and I am convinced it was due to my over-zealous registry cleaning. The problem was with Aston2, an Explorer replacement shell. Just for the halibut, I switched from the Aston2 shell to the Explorer shell. Everything was fine, as I had hoped. Went back to the Aston2 shell, the icons were dead again. Problem isolated. Uninstalled and reinstalled Aston2; problem solved!

Mally [FONT=&quot]☮[/FONT]

[FONT=&quot][/FONT]
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top