Solved: Update drivers for NetGear

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Cheryl

Thread Starter
Joined
Jul 20, 2001
Messages
663
I am running Vista and am having problems with hanging web site pages. A lot of times it will say "not responding" so I have to wait for a minute until it unfreezes. Someone thought it might be a driver issue for NetGear router. How do I find the right driver and how do I find out if a update is required?
 
Joined
Jul 22, 2006
Messages
8,450
Your router doesn't need a driver, so look elsewhere for the problem.
Such issues are most often caused by malware, but check that all your Windows updates are complete and look at Java Adobe, defrag and Chkdsk.
Start with SAS.

http://www.superantispyware.com/
 

Cheryl

Thread Starter
Joined
Jul 20, 2001
Messages
663
Well after running all the scans, etc. (which didn't improve my situation) I reinstalled Firefox. Unfortunately I lost all my bookmarks but was able to import from Internet Explorer. So far all websites are responding.

Thank you for your reply.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top