1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: USB 2.0 - Doesn't Seem to Work Properly

Discussion in 'Hardware' started by elitephotos, Oct 29, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. elitephotos

    elitephotos Thread Starter

    Joined:
    Jun 27, 2005
    Messages:
    23
    I have a newely built computer, a P5LD2 Asus Motherboard, 2 gigs of Corsair Memory, 3.4 Pentium D Dual-Core Processor. When ever I plug my external hard drives into a USB plug, a message reads as follows: "This USB divce can perform faster if you connect it to a Hi-Speed USB 2.0 port." Now, this motherboad indicates that the USB ports are 2.0 and I have tried all USB ports and get the same error. I have had no such error on my previous computer. Any suggestions? I have also tried to instal USB 2.0 drivers, but with Microsofts Service Pack 2, it indicates that drivers for USB 2.0 do not need to be installed and it doesn't give me the option to install them anyways.

    What should I do?

    Thank you!
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    You don't need additional USB drivers with 2K or XP if you have the current service packs installed. Did you install the MB chipset drivers? You do need those.

    What do you see under USB Controllers in Device Management, does the word "Enhanced" appear on at least one USB Host Controller?
     
  3. elitephotos

    elitephotos Thread Starter

    Joined:
    Jun 27, 2005
    Messages:
    23
    I have the MB drivers installed and it does not say "Enhanced" on any USB Host Controllers....here is a listt of the USB controllers:

    Intle(R) 82801 GB USB Universal Host Controller - 27C8
    Intle(R) 82801 GB USB Universal Host Controller - 27C9
    Intle(R) 82801 GB USB Universal Host Controller - 27CA
    Intle(R) 82801 GB USB Universal Host Controller - 27CB
    USB Root Hub
    USB Root Hub
    USB Root Hub
    USB Root Hub

    That is it! What do I need to do? Is there a USB 2.0 Enhanced and a USB 2.0? I always thought USB 2.0 was one in the same. Please Help! Thank you.
     
  4. newhen

    newhen

    Joined:
    Apr 9, 2006
    Messages:
    166
    yah try drivers
    does is give a pop-up window?
    sometimes is says that with me and it ask to install new drivers im not sure running vista right now so i mit have to check with xp
     
  5. elitephotos

    elitephotos Thread Starter

    Joined:
    Jun 27, 2005
    Messages:
    23
    When I insert the disc for the mobo and click on "USB 2.0 Driver", I get the following pop-up in notepad:

    Windows XP USB2.0 Driver Installation
    ====================================

    Please using Windows XP SP1 (Service Pack 1) or later versions, you DO NOT need to
    install this driver, because they already contain software support for USB 2.0.
    _______________________________________________________________________

    That is it! I am running Microsoft Windows XP Professional Version 2002 Service Pack 2

    Any Suggestions?
     
  6. newhen

    newhen

    Joined:
    Apr 9, 2006
    Messages:
    166
    have you installed the drivers windows can be like that sometimes -:p
    bill gates of course:p
     
  7. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    You do not have USB 2.0 being recognized. Have you checked in the BIOS to make sure the USB 2.0 capability is enabled? Have you installed the correct motherboard drivers for this board? The message you're getting is correct, you don't need USB 2.0 drivers, they're built into XP with SP2.
     
  8. elitephotos

    elitephotos Thread Starter

    Joined:
    Jun 27, 2005
    Messages:
    23
    Thank YOU! problem solved....was not enabled in the Bios....i had a tech company installed the new mobo because i messed up my old one...i thought they would have made the changes to the Bios...Thank you everyone for your help!
     
  9. Rich-M

    Rich-M

    Joined:
    May 3, 2006
    Messages:
    22,443
    Oh brother that is unbelieveable...
     
  10. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,418
    You can mark your own threads solved using the thread tools at the upper right of the screen.
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/513901

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice