1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved: USB Thumb Drives won't give me a drive

Discussion in 'Hardware' started by chiefbutz, Sep 25, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. chiefbutz

    chiefbutz Thread Starter

    Joined:
    Sep 25, 2006
    Messages:
    11
    I am running XP Media Center, I have tried plugging in the 2 thumb drives I have and neither gives me a drive. I have gone to the disk manager and it isn't assigning them a drive letter. I tried to assign it manually but it still will not show up in my computer. I have tried uninstalling the device and reinstalling it. I have tried enabling and disabling it. I have tried all of the ports on my laptop, along with one going thorugh a USB hub. Anymore suggestions?
     
  2. toniaxp

    toniaxp

    Joined:
    Sep 23, 2006
    Messages:
    67
    Check your drives on another PC to make sure they work. Also try and get the latest drivers for them which may be more compatible with WinXP
     
  3. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    Trying them in another machine is a good idea, but no drivers are required for ME/2K/XP for USB attached storage, so don't go loading any 3rd party drivers. :)

    What are the exact symptoms? Does the device show up in Device Manager? Do you get the connect/disconnect tone when you plug it in and remove it? Do you see it in Disk Management?
     
  4. chiefbutz

    chiefbutz Thread Starter

    Joined:
    Sep 25, 2006
    Messages:
    11
    It works on another computer, it shows in Device Manager and says it is working properly, it shows in the Disk Manager. Disk Manager doesn't show it having a drive letter. When I manually assign one it still does not show up in My Computer.
     
  5. WhitPhil

    WhitPhil Gone but never forgotten Trusted Advisor

    Joined:
    Oct 4, 2000
    Messages:
    8,684
  6. chiefbutz

    chiefbutz Thread Starter

    Joined:
    Sep 25, 2006
    Messages:
    11
    Fixed, thanks
     
  7. WhitPhil

    WhitPhil Gone but never forgotten Trusted Advisor

    Joined:
    Oct 4, 2000
    Messages:
    8,684
    Using the Registry fix, or some other means???

    As well, you can mark this thread as Solved using Thread Tools at the top
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/504120