Solved: Video Card Issues With Ubuntu 7.10

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

LuckyStrike502

Thread Starter
Joined
Oct 12, 2006
Messages
97
I am a first time Linux user, and I just uninstalled Windows and installed Ubuntu 7.10 on my older HP Pavilion 7850. I kept my NVIDIA GeForce FX 5500 PCI video card installed while doing this, hoping it would recognize it and install the drivers, but it automatically recognized my Intel onboard video. I cannot completely get into Ubuntu with the GeForce FX 5500. It stops and goes to a black screen right before loading. However, it loads up just fine when I remove the GeForce FX 5500, and use the onboard video. I went into the BIOS to see if I could disable the onboard video, but I can't. There's only an option for onboard 512K and onboard 1MB. No option to disable it. Does anyone have any ideas, or know how I can resolve this issue? Any help would be greatly appreciated. Thanks in advance.

Jason
 
Joined
Sep 12, 2003
Messages
20,583
Hi LuckyStrike502,

Perhaps the information in the Ubuntu Starter Guide for Fiesty (7.04) also applies to Gutsy (7.10) - just don't use any fiesty settings:

Guide here.

-- Tom
 

LuckyStrike502

Thread Starter
Joined
Oct 12, 2006
Messages
97
Well, I think I have something wrong with my onboard video now. I can turn on the computer and see the Ubuntu screen while it's loading, then after the progress bar finishes loading it doesn't get into Ubuntu. It just has a bunch of lines going up and down on the screen and I can't see anything but those lines. I have no idea what happened because I was able to run Ubuntu perfectly fine before. Now I can't get it loaded to install the drivers I need for my NVIDIA card. Could this actually be a problem with my onboard video if I can see everything else on the screen before I see those lines? Oh, to to be more clearly about these lines, it kind of resembles a "snowy" screen, except it's a bunch of lines. I even tried to run in recovery mode with no luck. Any ideas?
 

tomdkat

Retired Trusted Advisor
Joined
May 6, 2006
Messages
7,148
Sounds like the refresh rate and/or resolution for your monitor is incorrect. I believe there is an option you can specify at boot time to have the system boot using a generic VGA driver. If you get your desktop back with the VGA driver, you can investigate the video adapter settings and make adjustments accordingly. Unfortunately, I don't know what the "VGA boot time" option is but it shouldn't be hard to find in the Ubuntu doc.

Peace...
 

LuckyStrike502

Thread Starter
Joined
Oct 12, 2006
Messages
97
OKay, I went ahead and reinstalled Gutsy, and I can now get to the desktop. I am currently using my onboard Intel video. As I said before, there is no way to disable the onboard video in BIOS, nor is there a jumper on the motherboard to disable it. Does anyone have any recommendations on installing an NVIDIA GeForce FX 5500 PCI video card? I don't want to do this incorrectly and cause another problem since I'm a Linux newbie. :)
 
Joined
Sep 12, 2003
Messages
20,583
I just searched for a "Gutsy Gibbon" Starter Guide and found it here.

Hope it helps your situation.

-- Tom
 

LuckyStrike502

Thread Starter
Joined
Oct 12, 2006
Messages
97
Yes, I found that starter guide already and tried it with no luck. I found that so many people have had trouble installing video cards on Ubuntu. I searched around and installed openSUSE 10.3 and it works flawlessly, so far. It automatically detected my NVidia video card, and the drivers were really easy to install. If anyone out there is having these same problems, or is new to Linux, I would highly recommend installing openSUSE.

Thanks for everyones help. :)
 
Joined
Nov 7, 2007
Messages
417
You've run into problems with Nvidia 3D Accelerator binary modules.

This is odd, as I have an older card, RIVA TNT2 which was correctly detected and handled by the Ubuntu install.

Having recently been on Nvidia's website, I think that card is now deemed 'legacy' and not supported by latest drivers.

I suspect this happened too late in the 7.10 release cycle for the installer to be modified, and that has caused an issue.

The solution is to install the older Nvidia driver rather than the latest for 3D. But and here's the gotcha, you'll need to be comfortable with the system, before you do that.

There should be a way, to force Ubuntu graphics installer to use the 2D 'nv' driver. I havn't got time to RTFM on Ubuntu site.

So the trick to getting a suitable /etc/X11/xorg.conf file, is to burn a Live CD like knoppix and see what it generates, then copy that file into /etc/X11/xorg.conf on your box. You should make a saved copy of the system one, and switch over in single user mode (telinit 1) after doing CNTRL-ALT-F1 to escape out of the X window system Login screen.

If you don't have a known working Nvidia driver, suitable for your kernel, then make sure that in xorg.conf where it says

[email protected]:~$ grep 'Driver.*\"nv' /etc/X11/xorg.conf

Driver "nvidia"

Change it to "nv" to switch to built in Open Source 2D driver in the Xorg server.

Later on you can chase up Nvidia 3D in various FAQs on Ubuntu & Nvidia websites, so you can play tuxracer & flightgear or whatever....
 
Joined
Sep 20, 2007
Messages
568
Remember if X is corrupt, hit ALT-F2 for a shell. ALT-F7 back to X. F3-F6 will open additional shells. Reinstalling is not necessary. This isn't windows :)

You can then either delete or edit your xorg.conf file to a setting you know your monitor can handle "800x600" and then Restart X '/etc/init.d/x11-common restart'

Sometimes this can occur just changing the monitor...
 
Joined
Nov 7, 2007
Messages
417
Good point, and if X starts but is not displaying properly on the monitor which is whining...

CNTRL-ALT-BACKSPACE immediately to kill the X server before any damage can be done.

If you were happy working in text console, I'd not bother with the 'Live CD' mentioned in my previous suggestion, that was purely for those requiring a GUI.
 
Joined
Nov 7, 2007
Messages
417
Found though I have "nvidia" driver display in Ubuntu 7.10, that actually it's not running the 3D game Planet Penguin Racer but freezing X Window on startup; have ran Earth3D in past so I thought the driver was OK.

Perhaps they've not sorted legacy Nvidia cards quite as well as it seemed, there again a real graphics driver issue could easily have locked up the machine, so perhaps it's an application problem.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top